PIP-4048MS and PIP-5048MS inverters

non-EV Solar, Wind and other renewable power sources
non-EV batteries and other energy storage stuff
Forum rules
Important!
This forum is for discussion of Non-EV matters.
solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Thu, 27 Aug 2015, 19:06

Will be good when these solid state li batteries become readily available. For the 4048 charging, it looks like you just need a break in the charging for it to go back into bulk charging mode.
Solamahn PNG

T1 Terry
Senior Member
Posts: 951
Joined: Thu, 30 Sep 2010, 20:11
Real Name: Terry Covill
Location: Mannum SA

PIP-4048MS inverter

Post by T1 Terry » Thu, 27 Aug 2015, 19:12

offgridQLD wrote: Floating a cell at 3.45v isn't floating it. It's charging it.

Kurt

I'm assuming there is some hidden meaning in that statement, but you will need to be a bit more obvious as cryptic clues are not my strong suite....
If a cell reaches 3.45v and goes no higher is it any different to a cell at 3.36v and goes no higher?

T1 Terry
Green but want to learn

User avatar
offgridQLD
Senior Member
Posts: 1825
Joined: Tue, 23 Jul 2013, 16:05
Real Name: Kurt
Location: Fleurieu Peninsula, SA

PIP-4048MS inverter

Post by offgridQLD » Thu, 27 Aug 2015, 19:29

If you are floating it beyond its rested 100%soc voltage then current will flow.

Float in the lead acid days was a maintenance voltage to maintain 100% SOC and overcome self discharge.Edit: you would always see some current flow with lead acid and that was ok.

Float with lifepo4 is just a way in stationary storage aplicactions (using charging gear with lead acid labels) to use (float) mode to cover loads and mantan your 100% SOC (or what you like to call 100% SOC) without any net charge flow to the cell from the point that you dropped into float.

I think where we disagree is the rested voltage of a full lifepo4 cell is.

"If the cell voltage drops below 3.4v rested, it was not fully charged, try recharging and measure how much goes in each time till the voltage holds 3.4v or better"

Kurt
Last edited by offgridQLD on Thu, 27 Aug 2015, 09:33, edited 1 time in total.

User avatar
offgridQLD
Senior Member
Posts: 1825
Joined: Tue, 23 Jul 2013, 16:05
Real Name: Kurt
Location: Fleurieu Peninsula, SA

PIP-4048MS inverter

Post by offgridQLD » Thu, 27 Aug 2015, 19:40

Perhaps also you dont get enough time in the day at float to see any negative effects of high float voltage. Considering my bank is often at float by 9:30am thats many hrs to go untill the sun drops and a long hot day of high float voltage and potential over charging if current is flowing (even a small amount)

It's easy to see if your overcharging if you have several shunts on your system all logging data 24/7
Last edited by offgridQLD on Thu, 27 Aug 2015, 09:43, edited 1 time in total.

User avatar
coulomb
Site Admin
Posts: 3721
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

PIP-4048MS inverter

Post by coulomb » Thu, 27 Aug 2015, 19:44

There is a new version of the PIP firmware at the MPP Solar web site:
http://www.mppsolar.com/manual/PIP-HS,% ... UPDATE%29/

This is version 72.40; last was 52.30.

I suspect that the differences are very minor, but of course minor changes can have major effects. I read somewhere that the phase locking is improved when in parallel mode, and that the fan speed control takes into account SCC charge current as well as inverter current. So if only the SCC needs cooling, it should get it. Also a minor change to the Q1 command (whatever that is; it's not documented in the protocol manual).

[ Edit: 74.40 -> 72.40. ]
Last edited by coulomb on Thu, 27 Aug 2015, 09:55, edited 1 time in total.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
offgridQLD
Senior Member
Posts: 1825
Joined: Tue, 23 Jul 2013, 16:05
Real Name: Kurt
Location: Fleurieu Peninsula, SA

PIP-4048MS inverter

Post by offgridQLD » Thu, 27 Aug 2015, 19:49

Nice,
     Is there any restriction on what model pip4848 can take the new software I recall a year was mentioned. Unfortunately I have lost the white date stamp sticker over my cover screw. So looking for other indicators of vintage.

Kurt
Last edited by offgridQLD on Thu, 27 Aug 2015, 09:50, edited 1 time in total.

solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Thu, 27 Aug 2015, 20:06

Has anyone tried loading 01 24 firmware for the scc
Solamahn PNG

User avatar
coulomb
Site Admin
Posts: 3721
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

PIP-4048MS inverter

Post by coulomb » Thu, 27 Aug 2015, 20:18

offgridQLD wrote: Nice,
     Is there any restriction on what model pip4848 can take the new software I recall a year was mentioned. ]
Since this one is so similar to the last one, the same restriction would apply, that is, don't install if manufactured before 2014.
[ Edit: the readme.txt in that folder applies to both versions, so they both officially require 2014 models. ]
Unfortunately I have lost the white date stamp sticker over my cover screw. So looking for other indicators of vintage.

The PCBs have dates on them in the silkscreen. Unfortunately, some of these are partially hidden under a barcode sticker.

Image

The 03 in the number on the left may also be an indication of a 2014 model.

There is also the serial port that has changed over the years, as in this post of Scott's.

[ Edit: Added "that has changed over the years"; larger image; mention readme.txt . ]
Last edited by coulomb on Fri, 28 Aug 2015, 03:48, edited 1 time in total.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
coulomb
Site Admin
Posts: 3721
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

PIP-4048MS inverter

Post by coulomb » Thu, 27 Aug 2015, 20:33

solamahn wrote: Has anyone tried loading 01 24 firmware for the scc

No. Note that there is also new SCC firmware, 4.00 as opposed to 1.24. That sounds like a larger change. I haven't searched to see what changes have been made to that firmware.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
offgridQLD
Senior Member
Posts: 1825
Joined: Tue, 23 Jul 2013, 16:05
Real Name: Kurt
Location: Fleurieu Peninsula, SA

PIP-4048MS inverter

Post by offgridQLD » Thu, 27 Aug 2015, 20:51

Thanks for that. I just found a very clear to see white date sticker. With the numbers 1-12 boxed in with the number 7 blacked out along side 2014 . Located In between the two + & - battery bus bars. July 2014 so I guess it's good to go.

Image

Great to see incremental updates. As some issues be it a small change from there end. Can have a big impact on the units functionality.

Kurt
Last edited by offgridQLD on Thu, 27 Aug 2015, 16:31, edited 1 time in total.

solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Thu, 27 Aug 2015, 21:02

Yes but I cant load either 1.24 or 4.00. Keep getting a debug assertion failure message.
Solamahn PNG

User avatar
coulomb
Site Admin
Posts: 3721
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

PIP-4048MS inverter

Post by coulomb » Fri, 28 Aug 2015, 03:04

solamahn wrote: Yes but I cant load either 1.24 or 4.00. Keep getting a debug assertion failure message.

Did you do the OCX registration process, and did it seem to succeed?
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

Tjadenw
Noobie
Posts: 16
Joined: Sat, 11 Jul 2015, 00:43
Real Name: Werner
Location: Cape Town
Contact:

PIP-4048MS inverter

Post by Tjadenw » Fri, 28 Aug 2015, 03:23

Voltonicpower revealed the 5KVA version of the updated model I mentioned earlier

http://www.voltronicpower.com/newspage.php?newsid=1075

its got 3 X MPPT trackers 180amp for a total of 9000W pv

solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Fri, 28 Aug 2015, 07:46

Got it working now. Will try both 1.24 and 4.00
Solamahn PNG

User avatar
weber
Site Admin
Posts: 2601
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

PIP-4048MS inverter

Post by weber » Fri, 28 Aug 2015, 08:04

coulomb wrote:
weber wrote: Does anyone know what the conditions are that cause a PIP-4048MS to drop out of float mode...

I suspect that it is a fixed voltage lower than the float voltage parameter. In fact, 4.0 V less. There would be a time required to be at this level, say 10 seconds or so, ...


Thanks Coulomb. Yes, 1 V below float is more like what we need for LiFePO4. When I get a chance, I'll try having the BMS send a serial command to the PIP, to raise the float voltage setting to more than 4 volts above the actual voltage for 10 seconds or so, when the BMS decides it's time to drop out of float mode.
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

Tjadenw
Noobie
Posts: 16
Joined: Sat, 11 Jul 2015, 00:43
Real Name: Werner
Location: Cape Town
Contact:

PIP-4048MS inverter

Post by Tjadenw » Fri, 28 Aug 2015, 23:49

I Noticed something concerning on my 24 volt 2.4KW model.

It relates to the battery type selection

When selecting Flooded or AGM the solar charging do not kick in and start charging, if is set it to utility charging it starts to charge but does not regulate. Went all the way up to 32 volt ! before I disabled the utility charger.

If I then change it back to USER the solar charger kicks in and start charging and both the utility and solar charger regulates the voltage properly.

Anyone encountered this before ? I do remember that it worked fine on Flooded when a got the inverter a few month's ago.


solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Sat, 29 Aug 2015, 00:05

I noticed that if starting voltage is above 25 then it goes straight into float. This is ok because if you start the day at 25+ you don't need bulk charging because the batteries are fairly full. I tried fld and ac charge starting at less than 25 volt and the battery voltage climbs to 29.2 and stays there. No float. If it works the same with solar charging, it is no big deal as long as your battery bank is big enough. 4048 charging works much better. 2448msx is good. Same charging as 4048 3000w but uses less idle power and house can be wired with 1.5mm.
Solamahn PNG

Tjadenw
Noobie
Posts: 16
Joined: Sat, 11 Jul 2015, 00:43
Real Name: Werner
Location: Cape Town
Contact:

PIP-4048MS inverter

Post by Tjadenw » Sat, 29 Aug 2015, 01:20

What I meant is if I select Flooded battery as my battery type solar don't eve float, no current flows to the batteries. then when I select utility only charging voltage climbs to about 32 volt ans stays there.

If i then change the battery type to USER solar starts charging as normal and switching to Utility charging the Voltage don't pass in bulk 29.2 and floats at 27.


Is almost as if my AGM and Flooded setting does not work only USER work

User avatar
weber
Site Admin
Posts: 2601
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

PIP-4048MS inverter

Post by weber » Sat, 29 Aug 2015, 01:23

solamahn wrote: I noticed that if starting voltage is above 25 then it goes straight into float. ... I tried fld and ac charge starting at less than 25 volt and the battery voltage climbs to 29.2 and stays there. No float.

What are your float and bulk voltage settings?
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Sat, 29 Aug 2015, 01:31

Fld sets them to 29.2 and 27 but it never goes to float just stays on bulk. I will connect a 2424msx now to batteries and ac and set o5 fld and leave it overnight. I bet the battery voltage is 29.2 in the morning. This one has 02 43 firmware.
Solamahn PNG

solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Sat, 29 Aug 2015, 01:43

With 02 43 firmware program 26 and 27 do not appear. I just connected it to ac and it went straight to float because start voltage was above 25. Lowered start voltage to below 25, now voltage at 29.2 and current 17A. Voltage will stay at 29.2 and current will taper off but unit will not switch to float.
Solamahn PNG

User avatar
weber
Site Admin
Posts: 2601
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

PIP-4048MS inverter

Post by weber » Sat, 29 Aug 2015, 01:49

Thanks solamahn. That confirms what Coulomb said. For a 24 V system the back-to-bulk voltage (25) is 2 volts below the float voltage(27). So for a 48 V system it will be 4 volts below and therefore almost never seen with LiFePO4 cells.
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Sat, 29 Aug 2015, 02:01

But a 4048 works different. It always goes to bulk regardless of the start voltage
Solamahn PNG

solamahn
Groupie
Posts: 121
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

PIP-4048MS inverter

Post by solamahn » Sat, 29 Aug 2015, 02:04

Just checked the 2424msx and it is now in float mode. Made a liar out of me. Did not do that the other day. Oh well. At least it is charging the way it is supposed to.
Solamahn PNG

Tjadenw
Noobie
Posts: 16
Joined: Sat, 11 Jul 2015, 00:43
Real Name: Werner
Location: Cape Town
Contact:

PIP-4048MS inverter

Post by Tjadenw » Sat, 29 Aug 2015, 22:54

weber wrote:
solamahn wrote: I noticed that if starting voltage is above 25 then it goes straight into float. ... I tried fld and ac charge starting at less than 25 volt and the battery voltage climbs to 29.2 and stays there. No float.

What are your float and bulk voltage settings?


when in user battery mode Set at 29.2 and 27 v

works perfectly in user mode however setting to flooded the solar charge controller stays in standby and do not start charging.


Post Reply