PIP inverter repairs and hardware modifications

non-EV Solar, Wind and other renewable power sources
non-EV batteries and other energy storage stuff
Forum rules
Important!
This forum is for discussion of Non-EV matters.
User avatar
Vissie
Noobie
Posts: 18
Joined: Sun, 02 Sep 2018, 07:24
Location: South Africa

Re: PIP inverter repairs and hardware modifications

Post by Vissie »

coulomb wrote:
Mon, 16 Jan 2017, 17:21
Here is the power flow topology for the PIP-4048, from "Axpert MKS-4000/KS-5000 Service manual", which I found on the web:

Image

As actually implmented:

Image
Hi Mike
Where in the diagram does he 4 x 3300uf capacitors go?

[ Edited Coulomb: trimmed most of the quoted text; original here. ]

User avatar
coulomb
Site Admin
Posts: 3941
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP inverter repairs and hardware modifications

Post by coulomb »

Vissie wrote:
Fri, 07 Feb 2020, 14:33
Where in the diagram does he 4 x 3300uf capacitors go?
At the very left, across the battery (after the 200 A fuse or fusible link), physically near the MOSFETs. The nearness guarantees a low inductance connection between the MOSFETs and the capacitors. They're what cause the splat if you connect the battery without a pre-charge circuit.

Edit: the "switches" on the left are the battery-side MOSFETs, while the "switches" to the righht of the transformer are the DC-DC bus-side IGBTs.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

Roman khan
Noobie
Posts: 26
Joined: Fri, 10 Jan 2020, 03:23

Re: PIP inverter repairs and hardware modifications

Post by Roman khan »

Vissie wrote:
Fri, 07 Feb 2020, 14:21
I googled J3 and Bc diodes but that left me in the dark
Googlre images shows J3 smd diodes as 18V zeners. Is that correct?
I cant find much on BC diodes
Do you have the diode values if zeners or the diode names that must be replaced?
Can this faulty components cause the 2 left hand side IGBTs to blow by maybe switching them at the same time and cause a short. I believe they work in an H bridge configuration
Thanks
Vissie
I don't know much about their voltage ,i think j3 is 16v zener and BC is 5 or 6 v zener.you can search here
http://www.s-manuals.com/smd
@weberand @coulomb can explain better.

User avatar
coulomb
Site Admin
Posts: 3941
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP inverter repairs and hardware modifications

Post by coulomb »

Roman khan wrote:
Fri, 07 Feb 2020, 19:22
I don't know much about their voltage ,i think j3 is 16v zener and BC is 5 or 6 v zener.you can search here
http://www.s-manuals.com/smd
The "J3" SMD marking code is for a Vishay 18 V zener diode; the BC is for one of two manufacturers whose part numbers end in C5V6. The 5V6 suggests 5.6 V, and clicking on the datasheet confirms this.

Old timers like me remember the BZY88-C5V6 through-hole 400 mW zener diode from Philips and Mullard. You can still find them as NOS (New Old Stock, i.e. never used, but not manufactured recently), e.g. https://www.silicon-ark.co.uk/bzy88-c5v ... by-philips . There are a number of modern components whose part numbers hark back to the old through-hole days, e.g. the 1N4148WS is the SMD equivalent of the very common through-hole 1N4148 general purpose fast diode.

SMD marking codes are short codes (often 2 or three letters and/or digits and occasionally a special character like an asterisk) that code for the actual part number. Of course, there aren't enough short codes to be unique, so sometimes you also have to use the package and sometimes also the general use category to find out what the part is, and sometimes the codes are just not unique, and you have to guess. No need for guessing in these cases. For example, the only two-leaded package that uses the J3 marking code is the Vishay zener diode. Clicking on the handy datasheet link leads to a table of zener voltages, test currents, etc for the various marking codes.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

solamahn
Groupie
Posts: 145
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

Re: PIP inverter repairs and hardware modifications

Post by solamahn »

Older type 4048ms case with new type scc
Attachments
Older 4048ms case with new type scc
Older 4048ms case with new type scc
B012C659-17D1-4D15-8767-7AA236A297C4.jpeg (3.25 MiB) Viewed 934 times
Solamahn PNG
24x300w, 2x4048ms, 75kw AGM
24x280w, JFY6000
12x300w, 4048ms, 20kw Winston
30x280w, 2x4048V, 35kw Winston

User avatar
Vissie
Noobie
Posts: 18
Joined: Sun, 02 Sep 2018, 07:24
Location: South Africa

Re: PIP inverter repairs and hardware modifications

Post by Vissie »

Roman khan wrote:
Fri, 07 Feb 2020, 03:28
There are three J3 smd diodes and three BC diodes in inverter soft start circuit.the encircle with blue line are j3 diodes and indicated by arrows are BC diodes.you should replace them even if they shows ok value.and the two 10nf smd capacitors indicated. Mostly fault53 comes from here.
Hi
I removed all 5 IGBTs that are driven from the opto driver ics and powered the board up
I measured all the correct voltages over that zeners and about 19.8V over D1, D2 and D19. This 3 diodes sits directly over the opto drivers supply pins 5 and 8. This voltages are isolated and used to drive the gates of high and low side igbts.
These diodes forms part of the isolated dc dc converters that drives the igbts
So I know that this zeners are ok. All I can still think that blows QB2 AND QD2 immediately is that the switching pulses are wrong and switches them on at the same time causing a dead short in the H bridge over them. I gave up on this one

On the one with switched power supply problem I found that the 5V output caused the supply to shut down through opto U13. After I completely remove q32 and also Q27,28,29 and 30 the supply came on with the correct voltages. The reason why this IGBTs blew was because there was a blown miniature resistor(R220) on one of U3 (SG3525) outputs. Another reason why we should always scope all the gates for signal by switching U3 on by shorting that 2 pins on the opto below U3 as suggested in the start of this thread by Coulomb or Weber
I also want to thank you guys for the diagram i found of the switched power supply and also the block diagram of this main board. It really made things much easier
Attachments
Isolated dc dc converter diodes.JPG
Isolated dc dc converter diodes.JPG (155.23 KiB) Viewed 848 times
Opto Isolated igbt drivers.JPG
Opto Isolated igbt drivers.JPG (137.72 KiB) Viewed 848 times

User avatar
coulomb
Site Admin
Posts: 3941
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP inverter repairs and hardware modifications

Post by coulomb »

Vissie wrote:
Wed, 12 Feb 2020, 16:19
I measured all the correct voltages over that zeners and about 19.8V over D1, D2 and D19. This 3 diodes sits directly over the opto drivers supply pins 5 and 8.
Are you sure? This would indicate a fairly substantial error in the schematic. I don't have a main-board handy to check at present. I assume that this was a 5 kVA model?
I gave up on this one
Sometimes you have to do that. But it looks like you gave it a really good try.
The reason why this IGBTs blew was because there was a blown miniature resistor(R220) on one of U3 (SG3525) outputs.
It would be really good to link to a schematic, for readers to be able to follow this properly. I'd like to include an index link to the switched power supply schematic that you mentioned; I could not find it with a 10 minute search.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
Vissie
Noobie
Posts: 18
Joined: Sun, 02 Sep 2018, 07:24
Location: South Africa

Re: PIP inverter repairs and hardware modifications

Post by Vissie »

coulomb wrote:
Wed, 12 Feb 2020, 19:19
Vissie wrote:
Wed, 12 Feb 2020, 16:19
I measured all the correct voltages over that zeners and about 19.8V over D1, D2 and D19. This 3 diodes sits directly over the opto drivers supply pins 5 and 8.
Are you sure? This would indicate a fairly substantial error in the schematic. I don't have a main-board handy to check at present. I assume that this was a 5 kVA model?


I gave up on this one
Sometimes you have to do that. But it looks like you gave it a really good try.
The reason why this IGBTs blew was because there was a blown miniature resistor(R220) on one of U3 (SG3525) outputs.
It would be really good to link to a schematic, for readers to be able to follow this properly. I'd like to include an index link to the switched power supply schematic that you mentioned; I could not find it with a 10 minute search.
Hi the best I can do at this stage is to post my notes on it and to repost your PSu diagram

Do you have schematics? Yes this is the 5KV model. That is the way it measured out
Attachments
5K switched power supply 001.jpg
5K switched power supply 001.jpg (340.87 KiB) Viewed 829 times
correct 5K block diagram 001.jpg
correct 5K block diagram 001.jpg (265.32 KiB) Viewed 829 times

User avatar
coulomb
Site Admin
Posts: 3941
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP inverter repairs and hardware modifications

Post by coulomb »

Vissie wrote:
Wed, 12 Feb 2020, 19:36
Hi the best I can do at this stage is to post my notes on it and to repost your PSu diagram
Ah! I thought that U3 was on a schematic that I posted, possibly for some other model. My mistake. It would sure be nice to trace out that U3 circuit one day. [ Edit: I mean, in more detail :) ] [ Edit 2: Duh! It's already done; see next post. ]

Thanks for your notes.
Do you have schematics?
No, nothing of relevance to this, unfortunately, and very little of anything else that's not already published.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
Vissie
Noobie
Posts: 18
Joined: Sun, 02 Sep 2018, 07:24
Location: South Africa

Re: PIP inverter repairs and hardware modifications

Post by Vissie »

coulomb wrote:
Wed, 12 Feb 2020, 19:19
Vissie wrote:
Wed, 12 Feb 2020, 16:19
I measured all the correct voltages over that zeners and about 19.8V over D1, D2 and D19. This 3 diodes sits directly over the opto drivers supply pins 5 and 8.
Are you sure? This would indicate a fairly substantial error in the schematic. I don't have a main-board handy to check at present. I assume that this was a 5 kVA model?
I gave up on this one
Sometimes you have to do that. But it looks like you gave it a really good try.
The reason why this IGBTs blew was because there was a blown miniature resistor(R220) on one of U3 (SG3525) outputs.
It would be really good to link to a schematic, for readers to be able to follow this properly. I'd like to include an index link to the switched power supply schematic that you mentioned; I could not find it with a 10 minute search.
Oh I found it in the firs post. Partial schematic trace of the inverter IGBT gate drive circuit.
Attachments
IGBT driver PS.png
IGBT driver PS.png (46.35 KiB) Viewed 807 times

Roman khan
Noobie
Posts: 26
Joined: Fri, 10 Jan 2020, 03:23

Re: PIP inverter repairs and hardware modifications

Post by Roman khan »

Vissie wrote:
Wed, 12 Feb 2020, 16:19
The reason why this IGBTs blew was because there was a blown miniature resistor(R220) on one of U3 (SG3525) outputs.
Is this R220 a 10ohm resistor? In my PCB there is no components numbering on back side. Please share photo of that part if possible.

User avatar
Vissie
Noobie
Posts: 18
Joined: Sun, 02 Sep 2018, 07:24
Location: South Africa

Re: PIP inverter repairs and hardware modifications

Post by Vissie »

Roman khan wrote:
Fri, 14 Feb 2020, 01:43
Vissie wrote:
Wed, 12 Feb 2020, 16:19
The reason why this IGBTs blew was because there was a blown miniature resistor(R220) on one of U3 (SG3525) outputs.
Is this R220 a 10ohm resistor? In my PCB there is no components numbering on back side. Please share photo of that part if possible.
Yes it is a 10 ohm.
Attachments
3E881F11-DE24-40AD-A0EC-796DD800D161.jpeg
3E881F11-DE24-40AD-A0EC-796DD800D161.jpeg (111.78 KiB) Viewed 765 times

User avatar
coulomb
Site Admin
Posts: 3941
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP inverter repairs and hardware modifications

Post by coulomb »

Vissie wrote:
Wed, 12 Feb 2020, 16:19
The reason why this IGBTs blew was because there was a blown miniature resistor(R220) on one of U3 (SG3525) outputs.
It would appear that R220 is on the output of U9, not U3. U9 is an SG3525; U3 is an ACPL-T350. Strange that the IGBT blew as a result of a part associated with the 400V-side MOSFETS. Did you perhaps mean one of the 47 Ω IGBT gate resistors, such as R144?
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
Vissie
Noobie
Posts: 18
Joined: Sun, 02 Sep 2018, 07:24
Location: South Africa

Re: PIP inverter repairs and hardware modifications

Post by Vissie »

coulomb wrote:
Fri, 14 Feb 2020, 08:13
Vissie wrote:
Wed, 12 Feb 2020, 16:19
The reason why this IGBTs blew was because there was a blown miniature resistor(R220) on one of U3 (SG3525) outputs.
It would appear that R220 is on the output of U9, not U3. U9 is an SG3525; U3 is an ACPL-T350. Strange that the IGBT blew as a result of a part associated with the 400V-side MOSFETS. Did you perhaps mean one of the 47 Ω IGBT gate resistors, such as R144?


Sorry for the confusion. This was for the fault where the switched power supply pulled down. It seems like Q27/28/29/30 that was blown and took R220 and two J3 diodes with it caused the power supply to not start

The fault where QB2 and QD2 explodes as the full bridge switch on, was where I checked the voltages over the zeners on the isolated dc dc converter. I suspect that this 2 igbts switches on at the same time causing a short. I gave up on this one

[ Edited Coulomb: fixed quoting. ]

solamahn
Groupie
Posts: 145
Joined: Thu, 18 Jun 2015, 00:09
Real Name: Julian Leach
Location: PNG

Re: PIP inverter repairs and hardware modifications

Post by solamahn »

These must be 4kw scc
Attachments
24F85483-5325-4BBE-92D9-FB2316080629.jpeg
24F85483-5325-4BBE-92D9-FB2316080629.jpeg (2.27 MiB) Viewed 655 times
CAC259F5-7290-44F9-9D79-7B0AA38ABE88.jpeg
CAC259F5-7290-44F9-9D79-7B0AA38ABE88.jpeg (2.37 MiB) Viewed 655 times
Solamahn PNG
24x300w, 2x4048ms, 75kw AGM
24x280w, JFY6000
12x300w, 4048ms, 20kw Winston
30x280w, 2x4048V, 35kw Winston

paulvk
Groupie
Posts: 228
Joined: Fri, 23 Oct 2015, 23:45
Real Name: Paul
Location: Sydney

Re: PIP inverter repairs and hardware modifications

Post by paulvk »

I thought this may be the most appropriate place to post the pictures of the remote display I am working on.
It is a Nextion paired with an Atmel AVR
This is displaying my two inverters actual picture of the Nextion screen
The zip file is an animation showing it working
Note its a personal project so if anybody wants to make one I can supply the files (not yet finished)
Dual_nverter.jpg
Dual_nverter.jpg (552.16 KiB) Viewed 640 times
Attachments
nextion.zip
(840.87 KiB) Downloaded 25 times

Walde
Noobie
Posts: 21
Joined: Fri, 17 May 2019, 23:48
Real Name: Dirk
Location: Germany / NRW / Solingen
Contact:

Re: PIP inverter repairs and hardware modifications

Post by Walde »

paulvk wrote:
Sun, 23 Feb 2020, 18:26
Note its a personal project so if anybody wants to make one I can supply the files (not yet finished)
Post the data at Github mail for everyone and post the link here.

Bentleyafrica
Noobie
Posts: 1
Joined: Wed, 11 Mar 2020, 23:27
Real Name: Rob Bentley

Re: PIP inverter repairs and hardware modifications

Post by Bentleyafrica »

Hi, I am new to this forum and thank you for all your interesting and helpful posts. As we have some power problems in our country I decided to upgrade my old large and very heavy inverter (Possibly 30 years old) to PV18-5K must20141231. A clone inverter of the Axpert. It worked fine once I connected it to my 48V Golf cart with 8 X T105 batteries. It ran a kettle induction stove fridges etc. I unplugged the power turned it off and back on and left it powering nothing. When I returned a little while later I had the error 09. Opened the box and found one mosfet blown open a total of 4 with short circuit.

My previous 5kva inverter also had blown more than 20 out of 40 mosfets. This golf cart has solar panels on the roof and is regulated by an Ardunio computer and a large relay (12v). My question is could the inverters have blown as a flyback voltage from this relay?

I am still going through the very helpful repair manual and am still checking for other faults. Hope to have this up and running soon. My old inverter used to fire up a Grid tie 4kw and basically give me extra power to run allot of devices inc the borehole. Could I risk this inverter to fire up a grid tie? Thanks again for a great forum. :)

catalincre
Noobie
Posts: 20
Joined: Sat, 12 Jan 2019, 14:56
Real Name: Catalin Cretu

Re: PIP inverter repairs and hardware modifications

Post by catalincre »

Hello world,
Error 01 fan locked
Error 01 fan locked
IMG_20200322_164248.jpg (3.64 MiB) Viewed 246 times
Becose of this error I have to take apart my inverter and due the fan mod with the arduino boards. Its all already prepared to solder on fan connection.
Arduino boards with step down boards
Arduino boards with step down boards
IMG_20200322_164222.jpg (3.67 MiB) Viewed 246 times

User avatar
Vissie
Noobie
Posts: 18
Joined: Sun, 02 Sep 2018, 07:24
Location: South Africa

Re: PIP inverter repairs and hardware modifications

Post by Vissie »

Good day
I have a problem on the switched power supply
The voltages are to low. The 12V is 11.2V. The 15V is 14V. All the capacitors are good
The inverter starts up and works for about 30 sec and than reset or switch the output off. It does not give an error code
Has anybody have an idea what can cause that?

User avatar
coulomb
Site Admin
Posts: 3941
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP inverter repairs and hardware modifications

Post by coulomb »

Vissie wrote:
Wed, 25 Mar 2020, 16:31
The voltages are to low. The 12V is 11.2V. The 15V is 14V. All the capacitors are good
If it was just that the voltages are low, I'd suspect the source resistors and components back to the Isense input (R205, R215, R225, C82), or possibly U10 itself.
The inverter starts up and works for about 30 sec and than reset or switch the output off. It does not give an error code
That sounds more like an overload somewhere, that is dragging the power supply down, and it eventually collapses. That would be hard to track down.

I see that +12 and +15 are down by the same amount (93% of nominal value). Are the others (±12 V, +5 V etc) all down the same amount? If one of them is down significantly more than the others, it could be the one that is dragging the whole power supply down. At least that would narrow the search a bit. The other thought is to use a non-contact thermometer to find parts that are overheating.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
Vissie
Noobie
Posts: 18
Joined: Sun, 02 Sep 2018, 07:24
Location: South Africa

Re: PIP inverter repairs and hardware modifications

Post by Vissie »

coulomb wrote:
Wed, 25 Mar 2020, 18:54
Vissie wrote:
Wed, 25 Mar 2020, 16:31
The voltages are to low. The 12V is 11.2V. The 15V is 14V. All the capacitors are good
If it was just that the voltages are low, I'd suspect the source resistors and components back to the Isense input (R205, R215, R225, C82), or possibly U10 itself.
The inverter starts up and works for about 30 sec and than reset or switch the output off. It does not give an error code
That sounds more like an overload somewhere, that is dragging the power supply down, and it eventually collapses. That would be hard to track down.

I see that +12 and +15 are down by the same amount (93% of nominal value). Are the others (±12 V, +5 V etc) all down the same amount? If one of them is down significantly more than the others, it could be the one that is dragging the whole power supply down. At least that would narrow the search a bit. The other thought is to use a non-contact thermometer to find parts that are overheating.
The voltages are as follow:
D57 on primary side of transformer only 13.8V( must be 15?)
D54 11.36V (must be 12v)
D67 8.83V to U5 (7805) 5V
D70 - 14.97v to U20(lm7912) -12v
R205,215,225 are good. Cant find C82
Will feel the board for warm components.

paulvk
Groupie
Posts: 228
Joined: Fri, 23 Oct 2015, 23:45
Real Name: Paul
Location: Sydney

Re: PIP inverter repairs and hardware modifications

Post by paulvk »

Have had two fans fail I replaced them with spare from spare inverter
have a source of spares been found?
Note they may have not been working for a while but as the inverters have temp controlled external fans it still worked and could not overheat.

catalincre
Noobie
Posts: 20
Joined: Sat, 12 Jan 2019, 14:56
Real Name: Catalin Cretu

Re: PIP inverter repairs and hardware modifications

Post by catalincre »

I would say YES, read my other posts. Any fan with same dimensions and pwm with 4 wires will work. Better and quieter.

User avatar
coulomb
Site Admin
Posts: 3941
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP inverter repairs and hardware modifications

Post by coulomb »

catalincre wrote:
Tue, 31 Mar 2020, 14:21
Any fan with same dimensions and pwm with 4 wires will work. Better and quieter.
Maybe the hardware has changed such that this is no longer an issue, but recall that @Weber had to replace the original fans in one customer's inverter. [ Edit: due to intermittent fan locked warnings, which might obscure more important warnings. ]
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

Post Reply