Unable to repair my Electron V

Technical discussion for the Blade
User avatar
Bryce
Senior Member
Posts: 447
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

Re: Unable to repair my Electron V

Post by Bryce »

Hi Chris - the problem with Blades is they are, well, not worth fixing unless you are a do-it-yourself sort of person. The cost to pay someone to do it is usually well more than they are worth when finished as they are all different and generally have unique problems built into them. (Plus paying others to work on a Blade will end up costing you more than the cost of buying a more reliable and parts-available older OEM EV). Additionally: even when going, Blades have far inferior range and EV tech than even an old iMiEV or Leaf. Old Leafs in particular are well supported by active communities, parts availability and dealers - plus Leafs themselves are well built and seem likely to last well into the future. If spending the sort of money to have someone work on a Blade - it is quite simply 'throwing good money after bad'. Even after fixing it, you will soon be up for the cost of a new battery pack anyway, as they are all getting quite old and were mostly all poorly battery managed.

I have heard of old Leafs needing new battery packs going for as low as $5k here. I'd suggest saving one of them from going to the tip!

Selling your Blade for parts to someone else with one who does their own work is a useful, non-wasteful end for it. They may even have a controller to fix it with! That in fact was my plan for an old long-range Blade I had here. My conversion van was reaching it's end-of-life, yet still had a good controller - and I had finally worked out how to match the controller to the AZD motor. Sadly Covid intervened and I had to sell the lot, plus my old Leaf, to stay afloat for 6 - 12 months of unemployment. (... ultimately including 6 months of being the full-time organiser of the many, many permutations of AEVA's 2020 EV Vision e-conference before it finally ran! ... but I digress ;-) )

Hope that helps - good luck with your decision making.

Kind regards
Bryce
Current EV drive: 2019 Kona electric
Also in family: 2019 Renault Zoe
Past drives: 2011 Blade Getz, 2011 Leaf, 2001 Citroen Berlingo conversion
Past Conversions: DC Berlingo, AC Berlingo, AC Sprinter
T1 Terry
Senior Member
Posts: 1309
Joined: Thu, 30 Sep 2010, 20:11
Real Name: Terry Covill
Location: Mannum SA

Re: Unable to repair my Electron V

Post by T1 Terry »

chris wrote: Mon, 22 Mar 2021, 17:40
Bryce wrote: Mon, 22 Mar 2021, 05:15 The best use for a Blade is as a glider to build your own EV using quality parts - the hard work has already been done and it is easier to reregister it as a repair than a complete new built conversion as the compliance re the battery boxes, engine mounts etc has already been worked through. Repairing the bastards is a pain as you keep finding more build errors and problems waiting to happen as you fix something else. Having owned a Blade, and having been a converter of vehicles myself - I have no regrets about moving on from it to a cheap early Leaf. (And more recently: a Kona :-) )

Cheers
Bryce
Looks like I have a new project. Learn how to install and setup a controller. Thank you for your helpful advice. I was hoping to just pay someone to do it for me.
Sent you a PM yesterday re purchase of the Blade ..... Easier to get a non running EV out of NSW than out of WA .....

T1 Terry
Green but want to learn
chris
Groupie
Posts: 69
Joined: Fri, 06 Feb 2009, 05:44
Real Name: chris
Location: sydney

Re: Unable to repair my Electron V

Post by chris »

T1 Terry wrote: Wed, 24 Mar 2021, 08:05 Sent you a PM yesterday re purchase of the Blade ..... Easier to get a non running EV out of NSW than out of WA .....

T1 Terry
I tried to reply but the message appears in the outbox as sent with nothing showing in the sent messages.

Edited Coulomb: fixed quoting.
User avatar
coulomb
Site Admin
Posts: 4803
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: Unable to repair my Electron V

Post by coulomb »

chris wrote: Wed, 24 Mar 2021, 19:52 I tried to reply but the message appears in the outbox as sent with nothing showing in the sent messages.
That's normal. When Terry reads your message, it will move from outbox to sent messages. Confusing terminology, outbox should be called something like unread.
MG ZS EV 2021 April 2021.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
Patching PIP-4048/5048 inverter-chargers.
T1 Terry
Senior Member
Posts: 1309
Joined: Thu, 30 Sep 2010, 20:11
Real Name: Terry Covill
Location: Mannum SA

Re: Unable to repair my Electron V

Post by T1 Terry »

Thank you Chris, I have received and replied. Car carriers seem to think like freight mobs when it comes to moving lithium cells, whack a premium on top because the customer will pay it no matter what ...... It would be cheaper for me to drive up there in my truck and bring it home .... just don't have the time spare at the moment because the workshop is going crazy with jobs they all want before Easter .... as in a week before Easter and that's today ......

T1 Terry
Green but want to learn
chris
Groupie
Posts: 69
Joined: Fri, 06 Feb 2009, 05:44
Real Name: chris
Location: sydney

Re: Unable to repair my Electron V

Post by chris »

coulomb wrote: Thu, 25 Mar 2021, 06:34
chris wrote: Wed, 24 Mar 2021, 19:52 I tried to reply but the message appears in the outbox as sent with nothing showing in the sent messages.
That's normal. When Terry reads your message, it will move from outbox to sent messages. Confusing terminology, outbox should be called something like unread.
Thank you for the explanation. You just reminded me that I still have that charger you repaired for me.
T1 Terry
Senior Member
Posts: 1309
Joined: Thu, 30 Sep 2010, 20:11
Real Name: Terry Covill
Location: Mannum SA

Re: Unable to repair my Electron V

Post by T1 Terry »

If all goes to plan, I should be the proud new owner of an Electron V. I have reached the stage of actually finding and purchasing a Gypsy/Dolly trailer to tow behind my motorhome in the Sydney area, so the plan is to pick that up on the way through to collecting the Blade Electron. Then I can drag it around the country side via an RV get together in Taggerty Vic and then on to the workshop in Mannum. From there the silly questions will start in a different thread while I try to fix the existing controller/swap out the controller for a Wavesculptor 200 that I have here or swap out the motor and controller with a combination of what I have on hand .... or throw my hands in the air and it this one to the collection :roll:

T1 Terry
Green but want to learn
User avatar
Randall679
Groupie
Posts: 75
Joined: Sat, 17 Dec 2016, 15:37
Real Name: Randall Berger
Location: Castlemaine, OZ

Re: Unable to repair my Electron V

Post by Randall679 »

Terry ...

I sympathise with you! I own an early Blade ... #4 I think ... and two more in storage without batteries ... They are certainly an acquired taste, but I think worth the effort. There is a chap in Newcastle names Jon Eggenhousen of Catavolt ... he would be a good bet to ask.

Cheers, Randall
T1 Terry
Senior Member
Posts: 1309
Joined: Thu, 30 Sep 2010, 20:11
Real Name: Terry Covill
Location: Mannum SA

Re: Unable to repair my Electron V

Post by T1 Terry »

Hi Randall, I have read a lot of your posts, were the ex Blade employees who lived around Castlemaine helpful as far as a knowledge base for the vehicles?
I'm looking at possibly increasing the pack voltage in an attempt to improve the range and the town gear speed, 40km/h isn't much use but 60km/h would be. The Tritium controller can handle up to 360v but no idea how much of the original blade stuff I'd have to replace. The specs for the DMOC say it can handle up to 400vdc with a max nom. of 336vdc so who knows. I'm guessing the controller is a 445 and not a 645, 53kW continuous would be great with a peak of 118kW but I doubt Blade were that generous :lol: 78kW peak and 38kW continuous are the more likely figures, and that would only be if you could keep it cool.
Should be an "interesting" project, if I have a win then maybe we can look at getting a few of the ones you have in mothballs back on the road with the EV smile that never seemed to be the norm from what I'm hearing from other Blade owners ;)

T1 Terry
Green but want to learn
User avatar
Bryce
Senior Member
Posts: 447
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

Re: Unable to repair my Electron V

Post by Bryce »

Hi Terry - yes, the Blades used a DMOC445, not a 645. However - don't bother trying to get an air cooled DMOC going. The only one I know that is still going well is an early one with a water cooled DMOC. For an air-cooled one: it is only a matter of time before it expires from heat exhaustion, and they cannot be repaired (as in even if you did succeed, something else would go not long after). DMOCs were the Achilles heel of Azure Dynamics. (Not helped by their placement in a dead air space in the Blades!)

The Wavesculptor using a higher voltage system goes well in them - however Tritium don't really provide much support for them any more.

Having repaired a number (too many!) Blades - I cannot emphasize enough that the best solution would be to rip all Blade installed motor, controller, BMS (and wiring) out and replace them with reliable parts that are readily available and wire it in a way that make sense. MUCH quicker, easier and ultimately cheaper - and results in an EV that is reliable to drive and can be fixed easily/quickly. I came to that conclusion after wasting WAY too much time trying to fault-find/diagnose/repair the existing systems as well as future proof the things from failing again. No two were ever wired the same, so any solutions I came up for one were of little use in the next.

Hope that helps.

Cheers
Bryce
Current EV drive: 2019 Kona electric
Also in family: 2019 Renault Zoe
Past drives: 2011 Blade Getz, 2011 Leaf, 2001 Citroen Berlingo conversion
Past Conversions: DC Berlingo, AC Berlingo, AC Sprinter
T1 Terry
Senior Member
Posts: 1309
Joined: Thu, 30 Sep 2010, 20:11
Real Name: Terry Covill
Location: Mannum SA

Re: Unable to repair my Electron V

Post by T1 Terry »

You're just trying to cheer me up Bryce :lol: Picked up the Blade from Chris and his wife, very nice people, the car was immaculate, one owner bought from Ross Blade himself. I also gained a second motor, second controller and second DC to DC converter for the 12v battery plus another charger that had been repaired by Coulomb for Chris previously ... what great score.
As we were heading down King Georges Rd one of those eletronic billboards lite up with, "snap Covid Lock Down, details at 6pm" The F word eascaped a few times and we did a dash for the Vic border just to make sure it wasn't going to be state wide with border closures. No real dramas on that leg of the trip and decided to park up for the night at a free camp on Lake Hume and I think this might have been the point the faeces hit the rotary oscillator. A very shape turn required to get back up the boat ramp where I'd made a wrong turn in the dark seems to have cause the guards on the Gypsy trailer to have intercourse with the sill rails up both sides of the Blade ..... not good. From there on it was a continuous battle to keep the Blade restrained toward the back of the Gypsy trailer and in the centre so the guards didn't attack the sills even more, a mixed result ending up with the Blade on top of the left hand guard after entering a supermarket car park. Finally got to our destination and made up a makeshift fix by using the ramps to lock the wheels in place and 2 more cargo ratchet straps to hold it down to the trailer ... it stayed in place all the way back to Mannum ..... the only other exciting bit was the goose neck bolt must have sheared off some where between Bendigo and St Arnaud resulting in dragging the hitch and trailer quite some distance grinding the chain links almost completely off one side of the link on each chain ... it was only the fact I was still pulling hard that kept it up off the ground some of the time and the remaining bits of the links didn't uncouple ......

Now I'm trying to get over a case of the Victorian chest cold variant that my wife generously passed on to me so I can catch up with the work load and get started on the resurrection of the Blade ... it does still drive, but that half throttle travel before the motor drive kicks in will be one of the first things I try to sort .... nothing, nothing nothing, two holes ripped in the lawn and a lurch out onto the driveway .... what were they thinking ?????

T1 Terry
Last edited by T1 Terry on Wed, 19 May 2021, 13:27, edited 1 time in total.
Green but want to learn
User avatar
Randall679
Groupie
Posts: 75
Joined: Sat, 17 Dec 2016, 15:37
Real Name: Randall Berger
Location: Castlemaine, OZ

Re: Unable to repair my Electron V

Post by Randall679 »

What was the outcome? I am interested because I am in the process of retro-engineering my Blade ... one of three ... two of the original team are neighbours here in the birthplace, Castlemaine, and we have decided to make it the ideal KISS EV. They were a bit over engineered to start with and no two were the same, so we'll see where we get to.

Hopefully, this will be the model for the KISS EV for the Recycled EVs business ...

To start, after 13 years, the batteries are clapped out, so I'm in the market for some batteries ... either packs or individual ... Originally had 42 Thunderskys ... I'm also going to junk the Azure controller and put in a Curtis.
T1 Terry
Senior Member
Posts: 1309
Joined: Thu, 30 Sep 2010, 20:11
Real Name: Terry Covill
Location: Mannum SA

Re: Unable to repair my Electron V

Post by T1 Terry »

Don't the Curtis controllers squeal under heavy load?
My first plan is to rework the one pedal throttle/regen idea so it doesn't feel strange, then look at the possibility of fully sealing the inner from the outer of the DMOC445 motor so I can trial my phase change cooling idea using one of the new E fluids on the market. A fluid with a phase change of say 50*C at atmospheric pressure could be moved up or down on the thermal range by putting the case internals under pressure or slight vacuum. The aim is for the E fluid to vaporise once it enters the motor so there would not actually be any liquid in there and the vapour would be easy to draw out through the upper body of the motor.
If that works then the next step would be to try and sort (with the help of local members) to see if we can sort the controller issues and then add a phase change cooler plate to replace the huge heat sink.
The heat extraction from the E fluid I'd like to experiment utilise the electric air con conversion to act as a heat pump to extract the heat from the E fluid and give me reverse cycle heating in winter and cool both the E fluid and cabin in summer.
I already have a few electric P/Steer pumps so I'll try that first, if it's not up to the task then an electric steering rack to replace the original. This way I can do away with the under engineered belt drive air con/P/Steer set up that used an electric motor way below the power requirements need to drive these two units .... another "What we they thinking" item.
If all of that happens without me going over the edge of sanity, the next move would be to attempt increasing the pack voltage to improve the over all range and performance. If I have a win there, the next plan is to build an LTO battery pack to that voltage so I can fast charge and never have to worry about replacing the battery pack for my remaining life expectancy (if it fails after spending all those $$ the wife would kill me so that part would be a safe bet :lol:)
I looked at swapping out for Tesla modules, but after the RIP Daisy video https://www.youtube.com/watch?v=WdDi1haA71Q I'm not too sure about the wisdom of such a conversion.

T1 Terry
Green but want to learn
T1 Terry
Senior Member
Posts: 1309
Joined: Thu, 30 Sep 2010, 20:11
Real Name: Terry Covill
Location: Mannum SA

Re: Unable to repair my Electron V

Post by T1 Terry »

Well, my 180 x 55Ah LTO cells look as though they will soon be on their way from China, they also have a holiday weekend so nothing will happen till Tuesday, but hopefully all will go smoothly.
Now I'll have to decide which vehicle to put these LTO cells in, the Silver Prius as a long range combined traction battery and range extender, or the Blade. I guess it will depend on the out come of the insurance claim after blowing up the Prius traction battery.

T1 Terry
Green but want to learn
Post Reply