Page 1 of 1

Problems with Electric Trike

Posted: Mon, 18 Aug 2014, 20:49
by Paul9
Hi people,
Apart from the Suzuki Swift, I also have an electric tricycle which I use to run around the farm in the Blue Mountains NSW. I bought it from the distributor in S.E. Queensland who imported them from China. It is a 48volt DC system with 100AH SLA batteries. It has a small tray at the back (similar to the tray on a ute) which is handy for collecting wood and other farm type activities.

A brief history is that I bought it in 2007 and after about 12 months the tricycle “died”. I was getting no response from the throttle. The distributor sent me a new throttle and problem was solved for about 6 months when throttle died again. Distributor sent me a new throttle which had a additional adaptor marked “Adaptor 3.6 to 0.7 N type” wired to it. Tricycle worked fine for 12 months and then died again. At this point the distributor was no longer contactable.

I bought a new throttle from EV Works but unfortunately the colour coding of the wires on the throttle does not match the colours of the existing wiring though we worked this problem out.

The problem is that now, when we turn on the ignition and then switch the trike into “drive”, it lurches forward a few inches and then stops dead. We get the same reaction if we put it into drive first and then turn on the ignition. Same reaction if we use reverse gear and switch it on.

Regardless of in which order we try to get it moving, it lurches forward and stops dead. We then have to wait 10 minutes and repeat the process and end up with the same result. We replaced the ignition switch with a simple on-off switch in case the ignition switch was the problem but it makes no difference.

Would anyone have any ideas about how we should approach fixing this problem? Any guesses at the likely cause?

I have tried many times to put pictures into posts and this time have had the same luck as previous times - zero, so can't show you pictures of the trike.

Thanks in advance
Paul




Problems with Electric Trike

Posted: Mon, 18 Aug 2014, 23:55
by Bluefang
Are you sure the throttle you got from EV works is the correct type, hall and pot throttles have different start and end points which will cause problems with the controller. Most will have a safety measure against wrong throttle inputs.

The throttle should output either 1-4V for hall or 0-5V for pot. If EV works sent you a hall throttle you could just get a simple 5K pot from the local electronics store to test it out. If you have a pot then try turning the trike on with the throttle pulled just under 1/4 of the way around.

Problems with Electric Trike

Posted: Tue, 19 Aug 2014, 00:23
by Paul9
Thanks Bluefang,

What I forgot to mention in my original message is that the trike lurches forward without us touching the throttle at all. All we do is turn it on and put it in gear and it lurches forward. We don't get a chance to turn the throttle.

I don't know if the above makes any difference to your "diagnosis" and solution?

To answer your question - no I don't know if I got the correct type of throttle so I will try and find out as per your recommendation.

Thanks again
Paul

Problems with Electric Trike

Posted: Tue, 19 Aug 2014, 20:29
by Richo
Paul9 wrote: I don't know if the above makes any difference to your "diagnosis" and solution?


It shouldn't.
As bluefang points out they may have different end points.
So even without touching the throttle it may be sending it the wrong value.

I would be looking at the old one and pulling it apart to see what parts were inside.

As a matter of interest what happens when you start it with it in the "full throttle" position?
This would eliminate if the connections is backwards - assuming a pot.



Problems with Electric Trike

Posted: Wed, 20 Aug 2014, 14:52
by Paul9
Thanks Richo,

I will be up the mountains where the trike is in about 2 weeks time so I will check the old throttle and also see what happens if I start (attempt to start!) the trike with the throttle on full.

Thanks
Paul

Problems with Electric Trike

Posted: Wed, 20 Aug 2014, 20:35
by Richo
Just be careful when you do it...

Problems with Electric Trike

Posted: Thu, 21 Aug 2014, 03:57
by Paul9
You mean as in:

a) Don't stand in front of it?
b) Don't point it at a cliff?

That sort of careful?

Problems with Electric Trike

Posted: Thu, 21 Aug 2014, 04:19
by Adverse Effects
/joking on
no there the fun parts
/joking off

yes when you try it the bike/trike "may" take off like a scolded cat but it could also act like it should do when your normally at 0% throttle

for that matter it could go up in flame (unlikely but would be cool to see)

Problems with Electric Trike

Posted: Thu, 21 Aug 2014, 18:57
by Paul9
Hi people,

Have checked the web site and the throttle I have is described as follows:


"Hall Effect Throttle suitable for ebikes and scooters.

- 3 Wire standard hall-effect configuration, red (+5V), black (GND), blue (signal out)
- 22mm diameter hole, 111mm long
- black rubber grip with chrome end"

Does that help with any of the diagnoses?

Thanks
Paul

Problems with Electric Trike

Posted: Thu, 21 Aug 2014, 20:22
by Richo
Not really.
It what comes out of the blue wire.
I could make assumptions but wouldn't guarantee it would be correct.

But it would suggest trying the full throttle may have no benefit - however fun it may be.

Problems with Electric Trike

Posted: Thu, 21 Aug 2014, 21:07
by Faz
It does point to the likelihood that the original throttle was a pot type though.
Meaning zero throttle = 0volts.
The hall effect throttle will have close to 1volt at its "zero throttle" position.

Problems with Electric Trike

Posted: Fri, 22 Aug 2014, 00:59
by Bluefang
Well you could test it by having the trike either on stands so the wheels can spin or against something that wont move, unplug just the blue wire and then turn the trike on. Then plug the blue wire back in and if the trike tries to move then yes you need to get a Potentiometer throttle. It should go to 1/5 throttle instantly.

Or get a cheap 5k pot that has a positive, ground and wiper connection. Hook it up and see if you can control the wheel speed. With the trike what color wires come from the controller? Are they the same blue, brown, black. The standard for pot throttles seems to be Brown is the signal wire, Blue is the 5V and black is the ground. So if you had to swap the blue and brown to even get a response then this is really pointing to needing a pot throttle.

Problems with Electric Trike

Posted: Fri, 22 Aug 2014, 03:56
by Paul9
Thanks people,

I'll check in two weeks time when I am next up the mountains and will let you know the result.

Cheers
Paul

Problems with Electric Trike

Posted: Wed, 17 Sep 2014, 13:39
by Paul9
Thanks people - you were right! (Why am I not surprised!)

I bought a 5k pot from Jaycar and wired it up to the trike and it works.
I assume now my task is to buy a pot type throttle?
Could anyone point me to a place where I can buy one please?

Thanks tons,
Paul

Problems with Electric Trike

Posted: Wed, 17 Sep 2014, 18:27
by EV2Go
I have often wondered if it would be better to use a much bigger and sturdier pot off a car and run a throttle cable off a normal bike to it instead of having the pot in the actual throttle. Still in two minds on that one for my trike.

Problems with Electric Trike

Posted: Thu, 18 Sep 2014, 20:31
by Richo
An alternative would be to use the hall throttle you have with a converter:

http://www.evworks.com.au/zeva-digital- ... -throttles

Problems with Electric Trike

Posted: Fri, 19 Sep 2014, 02:27
by Bluefang
Google "magura pot throttle"
Its the most common pot throttle but if you can get your hands on a converter that you can put in a water proof place then the hall throttle you have is better if you are planing to ride in the rain etc.

EV2Go i would have a look at using a normal motorbike throttle linked with http://www.endless-sphere.com/forums/vi ... 31&t=58801.
Reliability of a hall sensor plus use any cable throttle you want.

Problems with Electric Trike

Posted: Sat, 14 Nov 2015, 19:16
by Paul9
Hi people,

I had trouble finding a throttle described as a "pot" throttle but eventually found a "thumb pot throttle" normally used on electric bicycle conversions. As usual the colour of the wires coming from the thumb throttle did not match the colours of the wires into the controller of my tricycle.

I tried different combinations of wire connections and eventually found a combination which got my tricycle to move. The problem I had was that the tricycle could move 20 or 30 metres until it struck the slightest of inclines and the trike would stop dead. It would also stop dead if I pushed the thumb throttle any more quickly than very gradually. In short, any load would stop the tricycle dead.

I assumed that maybe the thumb throttle might be too "weak" to handle my 48v setup so I hunted around for a pot throttle suitable for a 48v system and eventually got myself the Magura twist grip pot throttle. The wires from the Magura, and to the contoller, according to the Magura instruction sheet, are listed as follows:

Blue = Top speed ..........Contoller wire = Red
Brown = Wiper (variable)....Controller wire = Blue
Black = zero speed .........Contoller wire = Green

Of course my controller doesn't have a Blue wire but has a black wire instead so I wired the connections as above but substituted my Black wire for the Blue wire. Tricycle didn't move an inch!

I then tried every other colour combination and found two different combinations which did work:

Magura Blue --- Controller Black
Magura Black -- Controller Green
Magaura Brown -- Contoller Red

and:

Magura Blue -- Contoller Black
Magura Black -- Contoller Red
Magura Brown -- Contoller Green

Both the above combinations worked BUT the tricycle will still only move if I twist the throttle VERY gently and only drive it on dead level ground. The tricycle would jerk to a stop when amps being drawn was as little as 5 amps at which stage the pack voltage (nominally 48v) was at about 42 to 44 volts dc.

Anybody got any guesses? Could the "new" problem be with the contoller or maybe the batteries or is the throttle still the likely cause?

Thanks for your help in advance,
Cheers
Paul

Problems with Electric Trike

Posted: Tue, 24 Nov 2015, 02:53
by EV2Go
Bluefang wrote: Google "magura pot throttle"
Its the most common pot throttle but if you can get your hands on a converter that you can put in a water proof place then the hall throttle you have is better if you are planing to ride in the rain etc.

EV2Go i would have a look at using a normal motorbike throttle linked with http://www.endless-sphere.com/forums/vi ... 31&t=58801.
Reliability of a hall sensor plus use any cable throttle you want.
This was more like what I had in mind. Could be mounted somewhere waterproof and a cable run to it.
Image