TC Charger Isolation Issue

How do you store and manage your electricity?
Post Reply
User avatar
4Springs
Site Admin
Posts: 694
Joined: Thu, 23 Dec 2010, 01:14
Real Name: Christopher Walkden
Location: Selbourne, TAS

TC Charger Isolation Issue

Post by 4Springs »

Hi all, I have discovered what seems to be an isolation issue with my TC Charger.
I have a 2kW TCCH-H175.2-12 and 48 LFP cells. The charger has the 0-5V control option.
I have now installed all of my cells and connected them together. I thought the first thing I should do now is to check isolation to chassis. I use the method described in E/ECE/324, regulation N. 100, which involves connecting a test resistor between HAZV and chassis and measuring the voltage drop across it.

I found that there was 300mA of touch current (if that is the correct term). Before upgrading to lithiums, my normal reading was about 0.05mA. Australian guidelines say it should be less than 20mA.

I tracked the source down to the new charger. There are two connections - the HAZV (+ & -, where only - is connected), and the 12V (+, - & control, where control is not connected to anything at the moment). If I unplug the HAZV from the charger (with 12V connected, then the touch current disappears. If I unplug the 12V (with the HAZV connected), then the touch current disappears. Touch current without charger connected is 0.02mA.

With the charger connected these are the voltages:
With the resistor connected between chassis and HAZV-, I read +10.1 (chassis = 0V).
With the resistor connected between chassis and HAZV+, I read +165.8 (chassis = 0V).
With the resistor connected between 12V+ and HAZV-, I read -2.3V (12V+ = 0V).
With the resistor connected between chassis and HAZV-, and 12V+ disconnected from the 12V battery, I read 0.0 (chassis = 0V).
Test resistance is 82k.

Is this a fault or a feature?
I thought I'd ask the nice folk here if there is something I'm missing before going to the supplier.
User avatar
jonescg
Senior Member
Posts: 3700
Joined: Thu, 21 Jan 2010, 23:05
Real Name: Chris Jones
Location: Perth, WA.

TC Charger Isolation Issue

Post by jonescg »

Many chargers use the 0 V of the traction battery as a reference for the 12 V electronics to drive it. I was working on a conversion where I'd regularly get shocks when touching a cell terminal and chassis. Like you, we worked out that it was the charger's 12 V supply.

If you use the charger's own 12 V output to dial the charger's power up or down, you should be able to avoid these isolation issues. You would need to put a Zener and resistor in there to make it a more consistent 0-5V signal, but you can avoid the shocks Image
AEVA National Secretary, WA branch chair.
User avatar
Johny
Senior Member
Posts: 3733
Joined: Mon, 23 Jun 2008, 16:26
Real Name: John Wright
Location: Melbourne
Contact:

TC Charger Isolation Issue

Post by Johny »

Jonescg is correct in that the charger's control signal is referenced to the traction pack voltage. If you are just providing an on/off signal later on then do as suggested and use the charger's 12V with a regulator or zener regulated supply and an opto-coupler or relay to isolate the charger control from the actual control you may use.
User avatar
4Springs
Site Admin
Posts: 694
Joined: Thu, 23 Dec 2010, 01:14
Real Name: Christopher Walkden
Location: Selbourne, TAS

TC Charger Isolation Issue

Post by 4Springs »

Thanks guys, I'm glad I asked here first!
My fault was that I didn't realise that 12V was supplied by the charger. I thought that I had to supply it to the charger. Now that I look back in the manual, it quite plainly says "12V internal power supply". I'll disconnect my aux 12V and use an optocoupler to interface to my BMS.
Post Reply