PIP-5048MK inverter

non-EV Solar, Wind and other renewable power sources
non-EV batteries and other energy storage stuff
Forum rules
Important!
This forum is for discussion of Non-EV matters.
suorama
Groupie
Posts: 31
Joined: Sun, 10 Mar 2019, 03:07
Real Name: Ari Sorvari
Location: Kangasala
Contact:

PIP-5048MK inverter

Post by suorama » Fri, 29 Mar 2019, 06:53

MODERATOR NOTES
This topic is for the PIP-5048MK inverter (also called the Axpert King 5K).

Other model numbers:
  • Mecer (rhymes with "spacer") SOL-I-AX-5KP

There are other topics for the
PIP-4048MS and PIP-5048MS inverters (also called the Axpert MKS 5K), and for the
PIP-5048GE, PIP-5048GK and PIP-5048MG inverters (also called the Axpert VM II 5000-48, Axpert VM III 5000-48 and Axpert MKS II 5K), and for
PIP inverter repairs and hardware modifications, and for the
Voltronic InfiniSolar inverters.


Index

Documentation
Firmware
  • As of November 2019, the manufacturer's firmware for the PIP-5048MK/Axpert King still contains the PV freeze bug. For that reason, we do not recommend that anyone purchase this model at this time. But for those of you who have already done so, we do at least have patched firmware that fixes the premature-float bugs.
    Coulomb and Weber's patched firmware: Suorama's notes on how he installed firmware.

    Warning! It is possible to brick these machines by attempting to flash them with firmware intended for other models, such as the PIP-4048MS or PIP-5048MS (e.g. versions 73.00 or 72.20, or patched versions thereof).
Other
END MODERATOR NOTES
====================================


[Post by suorama]

Image

Finally I start that projekt. Old ones is removed and new ones is installed to wall. Battery is installed permanent way (before I make battery investment) and PV side is almost ok. Only one needs better cable soon. AC input must do better and AC out must install. I need few components to AC side before I can manage it that way what I want =)

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by coulomb » Fri, 29 Mar 2019, 08:38

Nice.

I presume that these are PIP-5048MKs, set up for three phase operation?
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

suorama
Groupie
Posts: 31
Joined: Sun, 10 Mar 2019, 03:07
Real Name: Ari Sorvari
Location: Kangasala
Contact:

Re: PIP-5048MK inverter

Post by suorama » Mon, 01 Apr 2019, 13:05

coulomb wrote:
Fri, 29 Mar 2019, 08:38
I presume that these are PIP-5048MKs, set up for three phase operation?
Yep.

Now there is problem with ICC. Because of some reason MK / King not passthrought communication. If I understand Manie right, that is MK / King problem, not three phase problem.

Installation itself works nicely. Now grid feeds MK:s and MK:s feed my house. So now I can follow all different phases load separately etc. =)

suorama
Groupie
Posts: 31
Joined: Sun, 10 Mar 2019, 03:07
Real Name: Ari Sorvari
Location: Kangasala
Contact:

Re: PIP-5048MK inverter

Post by suorama » Sat, 13 Apr 2019, 19:09

There is a "little" problem with PIP-5048MK (Axpert King) when used parallel. Inverters information cannot collect thru one inverter, like PIP-4048MS.
I contact MPP solar support, and do few tests what they want to me to do. Today I got email where they promise new firmware by end of may.
I hope that helps also others with these new models, if that firmware solve problems. =)

apam
Noobie
Posts: 2
Joined: Mon, 15 Apr 2019, 05:10

Re: PIP-5048MK inverter

Post by apam » Mon, 15 Apr 2019, 05:34

hi, i have same problem with comunication between inverters 5048MK.
I can't disallow charging from utillity. i try to set par 16 for every possibility, but it looks that inverters alwais charging from utillity. do you have same problem?

Robbe01
Noobie
Posts: 3
Joined: Mon, 15 Apr 2019, 16:45
Real Name: Torsten

Re: PIP-5048MK inverter

Post by Robbe01 » Mon, 15 Apr 2019, 16:55

yes, exactly, I have the same problem.
The next problem is that switches the 5048MK at exactly 50V to mains voltage. Although point 12 48V are registered. My lithium ion battery never empties than 50V = 3.6V per cell. In addition, with 10A the battery is then charged with mains current. Here, too, is registered in point 11 2A. The inverter has its own life.

Robbe01

suorama
Groupie
Posts: 31
Joined: Sun, 10 Mar 2019, 03:07
Real Name: Ari Sorvari
Location: Kangasala
Contact:

Re: PIP-5048MK inverter

Post by suorama » Wed, 17 Apr 2019, 03:05

Yes, there is multiple problems. Or I cannot understand right how they think how inverter should behave.
But I think it is better try to solve problems one by one. Maybe it is easier to them.
I have also problem with PV power or current calculating. Inverters show example 60W PV power, (two gives 24W and 36W. Third has not now connected to PV yet).
But if I look my battery monitor (Victron BMV 700) it shows example 12A charge. Even battery mode and with out AC in.
That seems to be ten times lower value than reality.

At the moment I do not try disallow utility charging. So, I cannot say anything about that yet. But I think, inverter try keep system to run. So maybe battery low level mean something with that? Just guess.

I can keep to try ask questions from them. But as I say, maybe it is better wait and solve these one by one. Because If we put all problems in same time, We do not newer get working firmware out. There is lots of important issues. My first was that I cannot follow my system by remote, what is important to me. Because I need investigate our consumption. After that I decide how much more PV I need and what is reasonable battery capacity.

User avatar
weber
Site Admin
Posts: 2623
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by weber » Wed, 17 Apr 2019, 09:31

Welcome @suorama @apam and @Robbe01. Thanks for your input. I started this new topic for the PIP-5048MK (Axpert King 5K) so your posts don't get lost in the huge PIP-4048/5048MS topic. I'm sure we'll be hearing a lot more about the MK in future.

Yes. Please let your suppliers know about the problems you are having, and ask them to fix them.
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

apam
Noobie
Posts: 2
Joined: Mon, 15 Apr 2019, 05:10

Re: PIP-5048MK inverter

Post by apam » Sat, 27 Apr 2019, 03:49

Hi,
I contacted the distributor and explained the problems. I got answers.
The problem of communication between inverters connected in parallel and WatchPower will be resolved in the next fw update.
As for uncontrolled charging from the distribution network, I have been told that this is intentionally to protect the battery to prevent deep discharge and possibly damage. The charging current in this case is limited to 2A unless otherwise set.
So be calm, because even though the inverter seems to live its own life, it actually works as it should. It's so on purpose.

I'd be more happy to have the inverter behave as it was set, because if I set it up, I got it for some reason ...

Robbe01
Noobie
Posts: 3
Joined: Mon, 15 Apr 2019, 16:45
Real Name: Torsten

Re: PIP-5048MK inverter

Post by Robbe01 » Mon, 29 Apr 2019, 20:44

thank you very much, my PIP 5048MK switches to mains operation from 50v. Although I can adjust 48V anyway, he will turn off the battery from 50V. I have a 14S 30KWh Li-ion battery. At 14S, it is still 3.5V per pack. So still enough air down.

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by coulomb » Mon, 29 Apr 2019, 21:56

Robbe01 wrote:
Mon, 29 Apr 2019, 20:44
my PIP 5048MK switches to mains operation from 50v. Although I can adjust 48V anyway, he will turn off the battery from 50V.
In the PIP-5048MS models at least, the inverter switches from AC-passthrough mode to battery mode when either of:
  • the battery voltage falls below the back-to-utility setting, or
  • the battery voltage falls below the battery cutoff voltage plus 2.0 V (48 V models).
This is of course confusing, as the 2.0 V figure is not documented anywhere (I know it only from reading the firmware). The back to utility and cutoff voltages would be expected to be separate and unrelated concerns. The 2.0 V offset may be different for the PIP-5048MK, but I suspect that similar logic is applied. (I have had no opportunity to read PIP-5048MK firmware as yet.)

So perhaps adjust down your battery cutoff voltage (setting 29), and see if that changes where the inverter switches to mains.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

Jaco Venter
Noobie
Posts: 9
Joined: Tue, 14 May 2019, 01:59

Re: PIP-5048MK inverter

Post by Jaco Venter » Tue, 14 May 2019, 02:19

Hallo everyone

I recently commissioned a Axpert King at my house. A few problems that is still bugging me includes:

1) THe PV Watts will fall away to 0 W the moment a load is introduced. (Not only for electrical motor loads) The Watts will come back about 30 seconds later.
2) The Inverter will freeze whereby the PV Watts fall to 0 and it will stay down until the whole system is switched off and on. Then the PV Watts are back again. (It happened twice today)

Would like to add some trends but does not know how to at this stage.

My installation is as follows:
1)15 off 340W AE Solar Panels
2) Axpert King 5K Inverter
3) 4 off Huawei 48V 100Ah LiFe batteries
3) Victron Battery Monitor
4) Raspberry Pi / ICC monitoring software

Firmware Update is 71.50 as purchased a month ago in South Africa.

I must say that it is extremely frustrating if the Inverter freeze and I'm not close by to reset the system.

affer
Noobie
Posts: 23
Joined: Sat, 11 May 2019, 20:06

Re: PIP-5048MK inverter

Post by affer » Tue, 14 May 2019, 02:26

Hello from denmark.. got a 5048mk on my wall with 3s2p 310wp panels... will follow this thread to get ideas :-D
using the setup now for server gear and television in the house :-D

Image

where do i normally get firmware updates from?

User avatar
weber
Site Admin
Posts: 2623
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by weber » Tue, 14 May 2019, 05:20

affer wrote:
Tue, 14 May 2019, 02:26
where do i normally get firmware updates from?
You normally get firmware updates from whoever you bought the inverter from. In your case, MPP Solar.
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by coulomb » Tue, 14 May 2019, 08:55

Jaco Venter wrote:
Tue, 14 May 2019, 02:19
1) THe PV Watts will fall away to 0 W the moment a load is introduced. (Not only for electrical motor loads) The Watts will come back about 30 seconds later.
That sounds very much like the Solar Charge Controller is getting reset. It could be getting reset by the DSP (main processor) via an RST command, or it might be panicking.
2) The Inverter will freeze whereby the PV Watts fall to 0 and it will stay down until the whole system is switched off and on. Then the PV Watts are back again. (It happened twice today)
My wild guess is that after a certain number of panics, the SCC completely switches off to protect itself.
My installation is as follows:
1)15 off 340W AE Solar Panels
That sounds like you have your panels configured as 3S, and those AE panels are 72-cell (from this page). Voc at 25°C is 46.74 V, quite high, so the total Voc would be approaching 140 V. So you will have quite high PV voltage. With the weather cooling off in the southern hemisphere, the voltage will creep higher. I know nothing about the King/MK Solar Charge Controller, but it has a 145 V max Voc the same as most PIP/Axperts, so I presume it's similar. The Axpert/PIP SCC starts derating (reducing its target power point) above 130 V of panel voltage. You say the problem appears when a load is introduced. Is it possible that it's actually worse when a sizeable load comes off? Then, the SCC will reduce its load on the panels, which will then increase in voltage, and the SCC may panic when the voltage approaches 145 V.

Perhaps you could monitor your PV voltage before and after one of these SCC resets? That should give an indication as to whether PV voltage is likely to be a contributor, or put that theory to rest.

I note that @affer is also running 3S, probably also 72-cell panels. He's from the northern hemisphere, but from a cold country (Denmark), so while this is a common arrangement, it's something you have in common.

The other thing is that 15 x 340 W = 5100 W, which is possibly too high for the King's SCC to handle. Sure, it only uses what it needs, but the higher the panel power, the quicker it will react to a given change in PWM ratio (how hard the SCC tries to draw power). Voltronic Power SCCs are prone to overshoots at the best of times, so with more PV power than they are designed for, they will likely overshoot and undershoot more frequently. Since you are already near the absolute maximum allowed PV voltage, changes in SCC load could result in undershoots which cause a quick rise in PV voltage, which might cause the SCC to initiate a panic reset.

Is it easy to temporarily turn off a string or two? If so, that would be an easy way to validate or disprove that theory.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

Jaco Venter
Noobie
Posts: 9
Joined: Tue, 14 May 2019, 01:59

Re: PIP-5048MK inverter

Post by Jaco Venter » Thu, 16 May 2019, 01:53

Mike

The highest total Power generated from the panels since installation was 3.3kW as the sun is low during winter (Bad angle towards panels)
I did test by switching off strings but it still happened that the PV Watts fell away.

I changed the operation yesterday to use Solar to charge the batteries while running on Utility and while the solar only charged the batteries the PV fell away a lot.

The open circuit Volts might be a possibility but why is it not only happening in the cold mornings? It also happens during the warm (25degree C) afternoons.

I will do a test whereby I will connect 2 panels in series and test with 6 strings as I did make provision for a 6th string. (Only 12 panels to be used but it should tell me something, I hope)

Can someone please inform me when updated firmware is released.

Regards

Jaco Venter
Noobie
Posts: 9
Joined: Tue, 14 May 2019, 01:59

Re: PIP-5048MK inverter

Post by Jaco Venter » Thu, 16 May 2019, 02:37

Mike

See attached the Trend for today:
Trend 2019 05 15.PNG
Trend 2019 05 15.PNG (92.84 KiB) Viewed 3088 times
It is interesting to see that there were more dips in the morning than in the afternoon.
Also interseting to see while the Inverter was in Bypass mode no dips occurred.
It might also be due to the batteries that were more charged in the afternoon.

What is your take on it?

[ Edited Coulomb: no need for [image=pixels] tag for attachments. ]

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by coulomb » Thu, 16 May 2019, 08:31

Jaco Venter wrote:
Thu, 16 May 2019, 02:37
It is interesting to see that there were more dips in the morning than in the afternoon.
But the effect isn't all that strong. There are fewer dips in the middle of the day, but several started at about 12:30, hardly the coldest part of the day.
Also interesting to see while the Inverter was in Bypass mode no dips occurred.
So that was the part near midday when the power exceeded 5400 W (presumably the graph clips there)?

I don't understand why that is. In line mode (where grid, solar, and battery power are all blended, presumably most of the graph outside that time in bypass mode), the solar and battery power is close, within about 300 W, until about 1pm when the mains stops providing power. So until 1pm, all the power from the panels (and it seems about 300 W from grid as well) goes into the battery. That doesn't change in bypass mode. So the load on the panels didn't change when it went to bypass mode. So I can't see any reason for the lack of dips then, apart from the fact that it happened to be the hottest part of the day.

Perhaps with new panels, the panel voltage is too high except in the hottest part of the day (at least, at this time of year, just before the start of winter).

Could you show a graph with PV voltage and PV power?
It might also be due to the batteries that were more charged in the afternoon.
I'm not seeing a connection there.

I'm intrigued by the other coloured dips. Most times that there is a green (PV power) dip, there is a purple (battery power) dip that goes negative. I tried to explain this, and deleted it as it didn't make sense. I assume that while PV power drops to zero instantly, it comes back gradually over about a minute, which we can't see on this graph due to the wide time scale. I can't see why the battery power would go negative either at the start or the end of the solar power dips.

Then there are occasional red (grid power) dips as well. It seems that sometimes, power is pushed back to the grid momentarily (negative grid power). Could that cause a problem for you? I understand that in most places, exporting power is not allowed, and some meters will actually disconnect if even a small amount of exported power is detected. But perhaps I'm misunderstanding the graph.

You seem to have a shading issue that disappears just before 11am, causing the solar and battery power to jump up about 300 W when the shade goes away.

[ Edit: utility → grid. ]
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

affer
Noobie
Posts: 23
Joined: Sat, 11 May 2019, 20:06

Re: PIP-5048MK inverter

Post by affer » Fri, 17 May 2019, 02:42

is the above picture from jaco a readout from the mk5048 ?

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by coulomb » Fri, 17 May 2019, 06:41

Yes.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

affer
Noobie
Posts: 23
Joined: Sat, 11 May 2019, 20:06

Re: PIP-5048MK inverter

Post by affer » Fri, 17 May 2019, 13:54

Which program?

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by coulomb » Fri, 17 May 2019, 16:00

That looks to be ICC.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

Jaco Venter
Noobie
Posts: 9
Joined: Tue, 14 May 2019, 01:59

Re: PIP-5048MK inverter

Post by Jaco Venter » Tue, 21 May 2019, 03:35

Hi Mike

Did a test over the weekend by connecting 2 panels in series and 6 strings.

Started up with that on Saturday morning and even before 08:00 the PV Watts dipped 4 times. I then changed it back to 3 panels in series and 5 strings.

What I also found is that if the PV Watts freeze up, I only need to switch of the DC feed from the panels to the inverter. After switching the DC feed on again the inverter start using the PV power again.

Something strange for me, and hopefully you can explain, is that when I switch the PV Infeed to the inverter off the PV volts on the inverter only drop from 124V to about 50V. I expected it to drop to 0V. Is there internal caps inside the inverter keeping some Volts or???

So after eliminating a few possibilities from the list I'm still experiencing frequent dips and a freeze or two per day.

Today it freezed when the batteries reached point where the system needed to change to Solar/Battery. THe moment it change fron Utility to Solar it ran for a while on Utility @ 165 Watts and the Solar supplied the load and the batteries. Almost if the Utility did not want to part from Battery charging as it is set to charge at 2Amps while Utility is on.

Otherwise the system was fairly OK today.

@affer do you experience anything like this with your system?

Some recommendations I received include the option to add an additional King in parallel. (Not to sure if it will solve my (or the Inverter) problem.

affer
Noobie
Posts: 23
Joined: Sat, 11 May 2019, 20:06

Re: PIP-5048MK inverter

Post by affer » Tue, 21 May 2019, 03:51

I dont see anything like you, ive used to have a 3024MSE but upgraded because i had more panels i would like to put on my roof.

atm i have 3s2p setup 310wp per panel, i attached to pictures, one where the batteries where not suffucient and i started charge with 10a from utility and the second from today where i had enough sun to charge the batteries.
Screenshot 2019-05-20 at 21.46.06.png
Screenshot 2019-05-20 at 21.46.06.png (744.91 KiB) Viewed 2964 times
Screenshot 2019-05-20 at 21.44.53.png
Screenshot 2019-05-20 at 21.44.53.png (933.97 KiB) Viewed 2964 times
So no major dips in pv, and no freezes.

hope you find out the problem Jako

XtractorFan
Noobie
Posts: 12
Joined: Wed, 01 May 2019, 18:44
Real Name: Colin

Re: PIP-5048MK inverter

Post by XtractorFan » Tue, 21 May 2019, 05:32

I'm also installing/commissioning a PIP-5048MK, no major problems so far, just minor glitches and niggles - but WatchPower is pretty dire ;)
Downloaded and got ICC working on a spare Pi today, but not activated the trial key yet - as it only lasts 7 days, so need to make sure everything works before kicking that off.

Now it's my turn to ask:
@affer - what software are you using to get those graphs?

Post Reply