PIP-4048MS and PIP-5048MS inverters

non-EV Solar, Wind and other renewable power sources
non-EV batteries and other energy storage stuff
Forum rules
Important!
This forum is for discussion of Non-EV matters.
User avatar
weber
Site Admin
Posts: 2623
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by weber » Thu, 23 May 2019, 09:51

Thanks @rinaldoparaipan, @vlan_one and @CrAzY_DrIveR. Coulomb and I love to hear when our work has been helpful. :)

vlan_one, I have added "Voltex MKS 5KVA" to the list of known model names on the index page. Thanks.

CrAzY_DrIveR, that's an interesting looking battery. But please wrap those spanners in some electrical tape, and please don't leave them lying on top of the battery. :o What kind of car is the battery from?
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

CrAzY_DrIveR
Noobie
Posts: 6
Joined: Mon, 11 Feb 2019, 20:34
Location: Portugal
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by CrAzY_DrIveR » Thu, 23 May 2019, 17:21

peugeot 106, same as all first gen psa (peugeot citroen)
the spanner was just for a few minutes it's all gone now :lol:

User avatar
weber
Site Admin
Posts: 2623
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by weber » Thu, 23 May 2019, 18:03

davirus wrote:
Tue, 21 May 2019, 12:10
it has very important point , when running in off-grid , if during winter time you have low solar power , the internal power consumption is higher than charging rate , in my case seems that 50W is too low for stopping the inverter to avoid discharging the batteries , it destroyed my batteries by discharing them , this setting should be set to a minimum 100W to overcome the internal consumption of the inverter , i need help doing that , i`ve search all over the net , i`ve tried all 3 options of parameter 4 , and now , i`ve written an email to support@mppsolar.com , i hove someone will reply.
Hi @davirus, I'm afraid you may have misunderstood the purpose of the power saving setting, and hence misunderstood the meaning of the power numbers in our abbreviated description of it.

SAv [04] nor    Power saving mode  Normal (AC on, DC-DC on, 50 W no load)
         SdS                       Saving disabled (AC on, DC-DC 33% when low load, 46 W no load)
         SEn    (when PAr = SnG)   Saving enabled (AC off when low load, 2 W no load)

Those numbers have nothing to do with the charge rate. They are the internal consumption of the inverter. The "nor" setting is the worst setting you could have used, as it is the one that makes the inverter have the highest internal consumption. If you don't have enough solar charging during the day, to overcome the self-consumption at night, even with power saving enabled (Sen), then there is nothing that we, or the the manufacturer, can do about it, by changing the firmware. Sorry.
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

vulcanescu35
Noobie
Posts: 11
Joined: Mon, 30 Oct 2017, 17:09
Real Name: Cristi

Re: PIP-4048MS and PIP-5048MS inverters

Post by vulcanescu35 » Tue, 28 May 2019, 01:36

Hi guys,

I have 2 pip 4048 MSD inverters which are working as parallel, and from 2 days I have a strange behavior, when commute from bateries to line (bypass) it has a kind of loop and a I have short interruption of energy and it is stay on this state for couple of minutes until enter on bypass mode. As I see it don't detect line even if is showing line and I can see voltage on display (220v).On the events I don't see any fault log, maybe communication lost/restore

After reboot with bateries cutting off and line, and boot again it will commute on bypass... But I didn't find a procedure wich work everytime.

I will tray to configure again as stand alone to see if it is working not in parallel mode.

Can u help me please with any advice?

Regards .

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by coulomb » Tue, 28 May 2019, 05:29

@ vulcanescu35,

Do you perhaps have the same problem as described in this post on the PowerForum?

https://powerforum.co.za/topic/3675-axp ... ment=55056

Edit: or maybe you're the same person.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

ned-kelly
Noobie
Posts: 1
Joined: Wed, 29 May 2019, 11:54

Re: PIP-4048MS and PIP-5048MS inverters

Post by ned-kelly » Wed, 29 May 2019, 12:01

Hi Guys, For anyone using Home Assistant (For their home automation) or thinking of using Home Assistant in the future (It totally rocks by the way)....

I've made a Docker based solution that can be run on a lightweight & cheap SBC (Such as an Orange or Raspberry PI) allowing you to interface with them finally with ease (the bundled Java app they give you “Watchpower” is a pile of S$$T and unreliable at the best of times)…

It works by both pull monitoring data (Via the RS232 or USB port on the Inverter) and sending to Home Assistant via MQTT, as well as actually programatically receiving commands (again via MQTT) to change the configuration of the Inverter on the fly - Depending on various automations you might setup (such as ‘only charge batteries off solar during the day’, then ‘charge batteries off the grid’ at night time after midnight when the price of power is cheaper if it's going to rain tomorrow/rest of week) etc…

Here’s the links for anyone who might be interested:
Hopefully this makes someone else’s life a bit easier also :)

Image

[ Edited Coulomb: fixed img tags]

User avatar
Greendrake
Noobie
Posts: 5
Joined: Sun, 09 Jun 2019, 19:55
Location: New Zealand
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by Greendrake » Sun, 09 Jun 2019, 20:19

Hello everybody! After a whole day of googling how to geek with my inverters I am pretty much excited to find this forum!

So, I happened to have bought a couple of clones with parallel kits installed (no branding at all, though sold as "Hybrid Inverter"):



They do have the solar charging bug mentioned earlier in this thread (reported power appears to be twice as much lower until you turn PV off and back on). They also do not accept AC input when in parallel mode (the AC input sign just flashes with no error code). When in single mode, the same AC input works just fine.

The firmware is 52.30. According to the decision tree it is tantamount to 72 "Else if the current firmware minor version is less than 40 then". However, I am not too sure that I have "5 kW (PF1) model with the 64 V option" as that entry says.

Can anyone please tell what firmware would suit in this case, if any? Unless there is certainty that I am going to brick them I feel brave to try updating one of the pair to see if it works :ugeek:

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by coulomb » Sun, 09 Jun 2019, 21:02

Greendrake wrote:
Sun, 09 Jun 2019, 20:19
They do have the solar charging bug mentioned earlier in this thread (reported power appears to be twice as much lower until you turn PV off and back on). They also do not accept AC input when in parallel mode (the AC input sign just flashes with no error code). When in single mode, the same AC input works just fine.
Interesting. But those don't sound like bugs that later firmware can fix, since older PIPs did not behave like that.
The firmware is 52.30. According to the decision tree it is tantamount to 72 "Else if the current firmware minor version is less than 40 then". However, I am not too sure that I have "5 kW (PF1) model with the 64 V option" as that entry says.
You certainly do not have PF1, and not the 64 V option either. I could not imagine how you came to that conclusion, until I "executed" the decision tree with the parameter "52.30" myself. I see I had a bug in my logic :!: Fixed now. In short, you could try 72.70c or really you may as well go to 73.00e. You even have the luxury of reverting back to factory firmware version 52.30, if it doesn't work. But as above, I don't expect it to fix your main problems, unfortunately. They seem to be rooted in imperfect copies of the hardware.

It's also entirely possible that you can't update anything at all. You may have early versions of the clones that later came with patched firmware 72.70c (lead acid flavour), but could not update firmware because they don't have a bootstrap loader. Both of these clones have the "¢" (cent) symbol in place of the "Φ" (Greek letter Phi symbol), so I'm guessing that they may be from the same factory and therefore have similar limitations.

Edit: actually, updating the firmware (if that's even possible) might fix the AC input problem, since the early versions did have a lot of problems with generators (another AC-in source), and they are less picky in later firmware versions (but far from forgiving of many generators, especially generators that aren't inverter based).
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

Walde
Noobie
Posts: 20
Joined: Fri, 17 May 2019, 23:48
Real Name: Dirk
Location: Germany / NRW / Solingen
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by Walde » Fri, 14 Jun 2019, 22:28

Hello everyone. Big problem i need help. :roll:

I have a problem with my EASUN Power "ISolar SM 5kw 48vdc" identical to PIP-5048MS (and unfortunately get no help from those)
(need a new motherboard) the posts are stubborn and do not work as a warranty case (error 09).
I have not had solar stoma for over 4 weeks now. It was just 60 days running. :cry:

Wanted at MPP Solar inquiries and where to buy a motherboard,
but they want to help me but only when the get a photo of the label of the inverter but the must be a MPP Solar (PIP-5048MS).

I just want to buy a motherboard!

And now I need your help.

Now I would need a photo of a sticker from a PIP-5048MS.

Can someone send me one by PM or here to send me. :roll:

User avatar
Greendrake
Noobie
Posts: 5
Joined: Sun, 09 Jun 2019, 19:55
Location: New Zealand
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by Greendrake » Sat, 15 Jun 2019, 14:20

coulomb wrote:
Sun, 09 Jun 2019, 21:02
you could try 72.70c or really you may as well go to 73.00e.
Thank you! Will give it a shot soon and report back if it fixes the AC input problem when in parallel.

The other "bug" with MPPT charging that I mentioned turned out to be my omission: I split the PV input in parallel between the two (paralleled) inverters. Somehow I assumed that they will coordinate MPPT charging between themselves (like they do AC output) to draw maximum power from the solar panels. Not the case (I later noted that the parallel kit manual says "CAUTION: Each inverter should connect to PV modules separately"). The result is that the PV power drawn by two parallel inverters together is 1.5 times less than by sole inverter! (and the latter is still less than can potentially be drawn as it hits the SCC limit of 3kW).

I am therefore wondering if there is SCC firmware capable of coordinating parallel SCCs?

paulvk
Groupie
Posts: 190
Joined: Fri, 23 Oct 2015, 23:45
Real Name: Paul
Location: Sydney

Re: PIP-4048MS and PIP-5048MS inverters

Post by paulvk » Sat, 15 Jun 2019, 19:24

Hello Greendrake
No you can not feed the two scc that way infact any charger that way they need their own sets of panels.

Walde I think error 09 is a software problem because its a Chinese copy of the inverter and you may need to load new software I seem to remember some one has done this search the posts.

Walde
Noobie
Posts: 20
Joined: Fri, 17 May 2019, 23:48
Real Name: Dirk
Location: Germany / NRW / Solingen
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by Walde » Sat, 15 Jun 2019, 19:39

paulvk wrote:
Sat, 15 Jun 2019, 19:24
Walde I think error 09 is a software problem because its a Chinese copy of the inverter and you may need to load new software I seem to remember some one has done this search the posts.
???????????????????????????????????

How do you know it's a clone?
I would tap on the boards on an original voltronic

Read: Trade Error 09 https://powerforum.co.za/topic/3655-pip ... rt-failed/

???????????????????????????????????
IMG_20190603_164440.jpg
IMG_20190603_164440.jpg (521.52 KiB) Viewed 1200 times
IMG_20190603_164410.jpg
IMG_20190603_164410.jpg (717.53 KiB) Viewed 1200 times
Wanted at MPP Solar inquiries and where to buy a motherboard,
but they want to help me but only when the get a photo of the label of the inverter but the must be a MPP Solar (PIP-5048MS).

I just want to buy a motherboard!

And now I need your help.

Now I would need a photo of a sticker from a PIP-5048MS.

Can someone send me one by PM or here to send me. :roll:

paulvk
Groupie
Posts: 190
Joined: Fri, 23 Oct 2015, 23:45
Real Name: Paul
Location: Sydney

Re: PIP-4048MS and PIP-5048MS inverters

Post by paulvk » Sat, 15 Jun 2019, 19:58

Its a clone because its made in China my ones are made in Taiwan MPP Solar are in Taiwan .
Page 104 has a picture of the label

Walde
Noobie
Posts: 20
Joined: Fri, 17 May 2019, 23:48
Real Name: Dirk
Location: Germany / NRW / Solingen
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by Walde » Sat, 15 Jun 2019, 20:11

paulvk wrote:
Sat, 15 Jun 2019, 19:24
Walde I think error 09 is a software problem because its a Chinese copy of the inverter and you may need to load new software I seem to remember some one has done this search the posts.
Which post do you mean? Have in the last few weeks the 100 pages certainly felt twice read.
Furthermore, I already had a broken TV on the board when the problem came 09

Serial is 929318041****5
as it is normal at voltronic or (last 6 are the serial number)

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by coulomb » Sat, 15 Jun 2019, 20:19

paulvk wrote:
Sat, 15 Jun 2019, 19:58
Its a clone because its made in China my ones are made in Taiwan MPP Solar are in Taiwan .
MPPSolar and the R&D section of Voltronic Power are in Taiwan. The machines are manufactured in mainland China by Voltronic Power. 90% of their work force is in mainland China.

Some stickers have "Taiwan Design", some "Made in China", some (like my own MPPSolar model) have neither. It's not consistent, unfortunately, especially with customised stickers.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

paulvk
Groupie
Posts: 190
Joined: Fri, 23 Oct 2015, 23:45
Real Name: Paul
Location: Sydney

Re: PIP-4048MS and PIP-5048MS inverters

Post by paulvk » Sat, 15 Jun 2019, 20:20

The post is titled "Do I Own a Clone?" it tries to help identify them.

DanoP
Noobie
Posts: 7
Joined: Tue, 28 Aug 2018, 16:44
Real Name: Daniel Petrik

Re: PIP-4048MS inverter

Post by DanoP » Thu, 20 Jun 2019, 16:38

mirceaalex001 wrote:
Thu, 24 May 2018, 14:34
My problem is that at night , the scc stays on , because somehow i get voltage on the scc coils ( driver 1 , driver 2 ) And i need a setting that will cut scc at higher voltage ( i have like 2volts + the battery voltage all the time on the pv input ,when the scc relay is connected ).If i change charging settings at night , and the relay disengage , evreything is ok untill next morning (The pv input voltage disapear )
Since 3 weeks ago I have same problem (PIP 4048MS) like mirceaalex001 describes. Night is coming but SCC do not go off. Instead is showing on PV input same voltage as is on battery (and there really is, but not coming from panels). When SCC is forced to restart than it is ok till next morning. I disconnect PV array, but it is same.
Did you find reason for that behaviour and solution?

DanoP
Noobie
Posts: 7
Joined: Tue, 28 Aug 2018, 16:44
Real Name: Daniel Petrik

Re: PIP-4048MS and PIP-5048MS inverters

Post by DanoP » Fri, 21 Jun 2019, 04:52

Additional info - SCC board measures wrong (higher) PV voltage. With disconnected PV array there is on PV input 53V (same as on battery) but SCC reads 55V (shown on LCD).
In QPIGS SCC reports battery voltage 52.95V, so at least measurement of battery voltage is OK, and in measuremnt of PV is some error in divider or AD.
Because PV voltage (55V) is higher than UBat (53V) it stays on.

User avatar
Tejota
Noobie
Posts: 20
Joined: Tue, 29 Nov 2016, 12:07
Real Name: MDKTejota
Location: Spain
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by Tejota » Wed, 26 Jun 2019, 00:24

Hi folks...

A question? What means error 72 on parallel setup ? Manual says : current sharing fault

Restart units solves problem but why happen? parallel setup has got few watts on load when error 72 started, about 100 Watts per unit more less.

Regards.

User avatar
weber
Site Admin
Posts: 2623
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by weber » Wed, 26 Jun 2019, 06:41

Hi @Tejota, I can only guess that maybe there is an intermittent bad connection on one of the current-sharing cables -- the twisted pairs of wires going into the green plugs. With the loads disconnected, or in bypass mode ([01]=uti), you could try pulling gently on each wire where it enters its plug, and tighten the clamping screws on any that move. You could also try unplugging each plug from the inverter and reinserting it, to remove possible contamination from between the contacts.
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by coulomb » Wed, 26 Jun 2019, 06:48

Tejota wrote:
Wed, 26 Jun 2019, 00:24
Restart units solves problem but why happen?
Have you checked the current sharing cables? (The wire pairs that terminate in small green plugs). These have been known to work loose (or were loose from the start but only played up long after installation), and have caused this error in the past. Another user had a loose neutral wire on one of the inverters' AC output terminals. Obviously the live wire could do the same thing.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
Tejota
Noobie
Posts: 20
Joined: Tue, 29 Nov 2016, 12:07
Real Name: MDKTejota
Location: Spain
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by Tejota » Mon, 01 Jul 2019, 21:38

coulomb wrote:
Wed, 26 Jun 2019, 06:48
Tejota wrote:
Wed, 26 Jun 2019, 00:24
Restart units solves problem but why happen?
Have you checked the current sharing cables? (The wire pairs that terminate in small green plugs). These have been known to work loose (or were loose from the start but only played up long after installation), and have caused this error in the past. Another user had a loose neutral wire on one of the inverters' AC output terminals. Obviously the live wire could do the same thing.
Yes. I rechecked all sharing cables. Everything is correct. Now is fault 80 (CAN data loss). Perhaps a board parallel is faulting ?

User avatar
coulomb
Site Admin
Posts: 3766
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by coulomb » Mon, 01 Jul 2019, 22:07

Tejota wrote:
Mon, 01 Jul 2019, 21:38
Perhaps a board parallel is faulting ?
Yes. Or it could be a CAN cable.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

User avatar
Tejota
Noobie
Posts: 20
Joined: Tue, 29 Nov 2016, 12:07
Real Name: MDKTejota
Location: Spain
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by Tejota » Tue, 02 Jul 2019, 04:59

coulomb wrote:
Mon, 01 Jul 2019, 22:07
Tejota wrote:
Mon, 01 Jul 2019, 21:38
Perhaps a board parallel is faulting ?
Yes. Or it could be a CAN cable.
WTF... But which one? I think fault board throw error 80 the first, after the others?? Is it correct?

CAN cable is very difficult to fault.

User avatar
weber
Site Admin
Posts: 2623
Joined: Fri, 23 Jan 2009, 17:27
Real Name: Dave Keenan
Location: Brisbane
Contact:

Re: PIP-4048MS and PIP-5048MS inverters

Post by weber » Tue, 02 Jul 2019, 08:13

You could try unplugging and replugging the internal cables that connect between the parallel board and the main board and control board.
One of the fathers of MeXy the electric MX-5, along with Coulomb and Newton (Jeff Owen).

Post Reply