STUCK IN ISOLATION

Technical discussion for the Blade
Post Reply
User avatar
Randall679
Groupie
Posts: 71
Joined: Sat, 17 Dec 2016, 15:37
Real Name: Randall Berger
Location: Castlemaine, OZ

STUCK IN ISOLATION

Post by Randall679 »

Hello, Blade Brains Trust ...

My Blade Electron has decided to get stuck in the "Isolation Check" stage of ignition ... all electrics work, brake compressor, battery cooling fan ... car batteries and 12V are fully charged ... but it won't move on from that stage ... and the auxiliary motor won't run ...

I could drive without the auxiliary motor, just no power steering. Now, even that isn't possible. It's some sort of hang up.

Any suggestions? Is it a fuse or connection? Sometimes it will hang there for a few seconds, but always "turn over" to the drive stage.

Yours in Frustration,

Randall
Blade Electron #4
Castlemaine
User avatar
coulomb
Site Admin
Posts: 4501
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: STUCK IN ISOLATION

Post by coulomb »

Randall679 wrote: Thu, 24 Dec 2020, 08:42 My Blade Electron has decided to get stuck in the "Isolation Check" stage of ignition
I don't know these cars well, but "isolation check" seems to indicate a leakage to chassis from the high voltage pack. Are you able to use a voltmeter and high power ≈10 kΩ resistor to try and find where the leakage is happening, if that indeed is the problem?
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.
Post Reply