Vacuum pump

Technical discussion for the Blade
Post Reply
antiscab
Senior Member
Posts: 2220
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

Vacuum pump

Post by antiscab » Fri, 13 Apr 2018, 17:07

Hi guys,

So the vacuum pump in my mk6 just died. Does anyone know where to get another one from? I imagine they're reused from another vehicle.
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

User avatar
jonescg
Senior Member
Posts: 2320
Joined: Thu, 21 Jan 2010, 23:05
Real Name: Chris Jones
Location: Perth, WA.

Re: Vacuum pump

Post by jonescg » Fri, 13 Apr 2018, 18:45

When you find one we'll order two... the Prelude will need one too
AEVA National Secretary, WA branch vice-chair

User avatar
mjcrow
Groupie
Posts: 83
Joined: Tue, 22 Apr 2008, 06:11
Real Name: Michael Crowley
Location: Adelaide

Re: Vacuum pump

Post by mjcrow » Sat, 14 Apr 2018, 09:22

Hi Matt, mine has part number 11C15AUA03D25, manufactured by YT Stable Tech Corp, http://www.yutai.tw/English/product.html
It looks like they used an aftermarket unit.

suziauto
Groupie
Posts: 90
Joined: Fri, 20 Mar 2009, 16:55
Real Name: graeme Manietta
Location: brisbane
Contact:

Re: Vacuum pump

Post by suziauto » Sat, 14 Apr 2018, 10:07

Hi ,

yup got heaps .. 2 cyd with mufflers and vac tank .. $450
$_57.jpg
$_57.jpg (165.12 KiB) Viewed 1755 times

suziauto
Groupie
Posts: 90
Joined: Fri, 20 Mar 2009, 16:55
Real Name: graeme Manietta
Location: brisbane
Contact:

Re: Vacuum pump

Post by suziauto » Sat, 14 Apr 2018, 10:09

We are in Brisbane .. suziauto@live.com.au or 0738087637 ..email or ring . DON'T reply here I come in once every few months so won't get your post..

Post Reply