repair of broken auxillary drive motor shaft

Technical discussion for the Blade
Post Reply
Bryce
Groupie
Posts: 140
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

repair of broken auxillary drive motor shaft

Post by Bryce » Wed, 07 Aug 2013, 16:27

Broken auxiliary drive motor shaft.
Symptom: sudden heavy steering and car even quieter than usual!
Diagnosis: missing shaft, pulley and belts. (Fell out on road. Was able to find all after a bit of searching though :).

Suggested remedy:
Replace armature
Upgrade shaft diameter to 20mm (from 16mm)

Job description:
Unplug aux drive motor power and encoder leads from mini controller;
Unbolt aux drive motor (4 bolts);
Drop off motor for rebuild;
Get either old pulley re-machined to new pulley diameter or get new one made (I did the latter).

Reinstallation notes:
Pay careful attention to:
-     Motor is running in correct direction (clockwise looking at the pulley) – check this before connecting belt. If running wrong way – see addendum/note below;
-     lining up pulley with steering pump and A/C;
-     proper tensioning of steering belt (can be a bit tricky as there is no tensioning arrangement for steering pump, unlike A/C, except to move the drive motor).

Parts suppliers:
Aux drive motor manufacturer: EMP, Bayswater (they can also modify the old pulley if it does not get lost when falling off!);
Engineering works for machining of new pulley if desired/required (mine had some wear and gravel rash, so replaced it).

Addendum/note:
In my case, the aux motor was running backwards after it came back. With a Seba 600 drive, this is easily rectified by using the ‘hidden’ keypad inside the controller – but careful attention must be paid to opening and resealing the controller box. Contact me for details. Earlier controllers require the swapping of a ‘jumper’ contact. Either way, Seba, (in Dandenong, Melbourne), are very helpful.

Bryce
Groupie
Posts: 140
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

repair of broken auxillary drive motor shaft

Post by Bryce » Wed, 07 Aug 2013, 16:30

Oops forgot to include the most important step:- perform the usual EV work precaution of isolating the traction pack before beginning!
Cheers
Bryce

User avatar
BigMouse
Senior Member
Posts: 600
Joined: Thu, 28 Oct 2010, 02:39
Real Name: Vincent Tannahill
Location: Silicon Valley
Contact:

repair of broken auxillary drive motor shaft

Post by BigMouse » Wed, 07 Aug 2013, 17:13

The the motor is running in the wrong direction, and it's a three phase motor, it's likely just an issue of swapping two of the motor leads. Unless the motor was re-wound as part of the rebuild, nothing could have been done to reverse the direction of rotation.

Bryce
Groupie
Posts: 140
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

repair of broken auxillary drive motor shaft

Post by Bryce » Fri, 09 Aug 2013, 15:07

Hi Bigmouse - it's a brushless DC motor that's encoder controlled - you need to swap both 2 power leads AND the right two encoder leads. If they are in conflict, the motor will just quiver and turn itself off. (Had that on the main drive motor of an AC conversion: 5 high speed reverse gears and a bloody slow single forward one, and just quivered and stopped when swapping any 2 power leads. Bloody confusing till we found out the right encoder wires had to be reversed too). I was having difficulty finding the right two encoder wires, so rang Seba to discover it was much easier to push a button instead!

And yes, how rewinding an induction armature can make it go the wrong way afterwards baffles me too - but it did. Thought it best to warn of any potential pitfalls and include their fixes. Hopefully nobody else has that particular hassle. :)

Cheers
Bryce

User avatar
BigMouse
Senior Member
Posts: 600
Joined: Thu, 28 Oct 2010, 02:39
Real Name: Vincent Tannahill
Location: Silicon Valley
Contact:

repair of broken auxillary drive motor shaft

Post by BigMouse » Fri, 09 Aug 2013, 16:50

Yeah, you're correct about the encoder leads.

I'm curious why the motor was re-wound while replacing the armature.

Bryce
Groupie
Posts: 140
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

repair of broken auxillary drive motor shaft

Post by Bryce » Sat, 10 Aug 2013, 15:45

Sorry Bigmouse - bit loose in my language - a rebuilt rotor, not a rewound rotor (or stator). Its a brushless DC motor. All new rotor to be perfectly correct: with larger diameter shaft and components. Stator untouched. If you can explain how that can make it go backwards after the rebuild, I'll go 'he'! But it did.

Simple fix with the Seba 600 controller as it turns out - IF you know an unmarked keypad is hidden inside the cover. Which is why I put the additional note in the 'fix' post.

Cheers
Bryce


arklan
Noobie
Posts: 1
Joined: Wed, 23 Apr 2014, 03:10
Real Name: matt
Location: wanneroo

repair of broken auxillary drive motor shaft

Post by arklan » Thu, 01 May 2014, 01:17

Bryce wrote:Had that on the main drive motor of an AC conversion: 5 high speed reverse gears and a bloody slow single forward one


this is gold :)

Bryce
Groupie
Posts: 140
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

repair of broken auxillary drive motor shaft

Post by Bryce » Thu, 01 May 2014, 02:30

And we have the video to prove it! Confused the hell out of us at the time. :)
Cheers
Bryce

Post Reply