New Blade Electron owner

Post up a thread for your EV. Progress pics, description and assorted alliteration
Post Reply
antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

New Blade Electron owner

Post by antiscab » Thu, 30 Jun 2016, 06:25

Hi Guys,

I appear to have been on a electric car collecting spree of late

Greg from Queensland was kind and generous enough to give me a Blade electron - thankyou Greg

It has a couple of gremlins I'm trying to chase down, but am a bit short on detailed info on the Blade cars

This particular one has the TM4 motor and controller

Does anyone happen to have any info on Blade Electrons that they're willing to share?
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

New Blade Electron owner

Post by antiscab » Thu, 30 Jun 2016, 06:52

I found a manual here:
Electron Manual
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

User avatar
jonescg
Senior Member
Posts: 2102
Joined: Thu, 21 Jan 2010, 23:05
Real Name: Chris Jones
Location: Perth, WA.

New Blade Electron owner

Post by jonescg » Thu, 30 Jun 2016, 15:29

You have it in Perth Matt? I'm going to be up for the WA branch AGM in August. It would be great if you brought it along to the meeting (assuming you sort the gremlins).
AEVA National Secretary, WA branch vice-chair

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

New Blade Electron owner

Post by antiscab » Thu, 30 Jun 2016, 18:55

I sure do

at present it is un-registered (it was easier to bring it across that way)
There's a bit of a vibration when driving in second gear that I need to look into before I can think about taking it over the pits.

I've only driven it around the block, but another issue that I have yet to replicate is power drops to a quarter intermittently. I'm thinking dodgy pot box, but hard to diagnose when you can't observe the problem
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

jeff ev
Noobie
Posts: 1
Joined: Fri, 01 Jul 2016, 04:58
Real Name: Jeff Pickett
Location: Adelaide SA

New Blade Electron owner

Post by jeff ev » Fri, 01 Jul 2016, 05:29

I have an early Blade Electron , the drop in power in mine is as a result of low battery pack voltage ,when it gets below 179v it will drop the power significantly (which allows the voltage to go up and gives full power which drops the voltage ect.ect.) Cheers Jeff . [Someone else has a Blade EV in the aeva, eastern states]

Bryce
Groupie
Posts: 115
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

New Blade Electron owner

Post by Bryce » Tue, 05 Jul 2016, 00:11

I have the electrical drawings for the Mark 5: pm me your email & I'll send them.
Cheers
Bryce
AEVA Vic committee member; AEVA national newsletter editor
Current EV drives:
2011 Leaf, 2001 Berlingo conversion
Past drive:
2011 Blade Getz
Past Conversions:
DC Berlingo, AC Berlingo, AC Sprinter

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

New Blade Electron owner

Post by antiscab » Tue, 05 Jul 2016, 05:56

ooo, yes please

I have a Mark 6, there may be some similarities between the two models
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

New Blade Electron owner

Post by antiscab » Sun, 17 Jul 2016, 20:33

Update, after some panel removal, I have identified the bms as an Orion unit. Cell count appears to be 100 cells, however, the whole battery is mounted underneath the car, imiev style. I have yet to be able to identify what cell size or construction it is.

Range appears to be down to 45km, with actual capacity around 7kwh

Does anyone have an Orion bms? If so, do you have the usb can cable?
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

New Blade Electron owner

Post by antiscab » Sat, 29 Oct 2016, 18:45

Update:

The vibration has progressively become worse, and now the car is dead :(

interestingly, the motor no longer spins even when the gearbox is in neutral.

I haven't had a chance to pull it apart to inspect the mechanicals of it - pictures to follow when I do.

Does anyone else here have a motor/controller manufactured by TM4?
I'm in need of diagnostic tools (so I can see what the controller is reporting)

Further inspection reveals the use of a Tritium EV Driver Controls module.

Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

New Blade Electron owner

Post by antiscab » Sat, 17 Jun 2017, 02:37

Update, I have started opening up the dead electron to see what can be salvaged.
The battery has turned out to be 108 series 20 parallel 26650 lfp cells of unknown origin. They're marked as 10.25wh

I'll need to do a capacity test. I had plans on pulling out the battery, repackaging and using it as a second battery in my other electron. Not so sure on that now, until I see how this giant spot welded and glued together thing comes apart.

Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

New Blade Electron owner

Post by antiscab » Sat, 17 Jun 2017, 02:43

ImageImageImageImageImageImageImageImage
Last edited by antiscab on Sat, 17 Jun 2017, 15:53, edited 1 time in total.
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

Tango
Noobie
Posts: 3
Joined: Thu, 22 Feb 2018, 17:26
Real Name: Tim Wight

Re: New Blade Electron owner

Post by Tango » Sat, 24 Mar 2018, 14:01

Bryce wrote:
Tue, 05 Jul 2016, 00:11
I have the electrical drawings for the Mark 5: pm me your email & I'll send them.
Cheers
Bryce
Hello Bryce,
The forum wont let me pm you henc my post
I have just got what i think is a MK4 or MK5 Blade and was hope you could send me the electrical diagram as it has some issues
plus do you know what the fully charged total voltage of the main batterys should be. Im getting 180 volts at rest and 190vafter 20secs of charge but the charger cct drops out withing 20-30 seconds.

Cheers Tim

Tango
Noobie
Posts: 3
Joined: Thu, 22 Feb 2018, 17:26
Real Name: Tim Wight

Re: New Blade Electron owner

Post by Tango » Sat, 24 Mar 2018, 14:12

Bryce wrote:
Tue, 05 Jul 2016, 00:11
I have the electrical drawings for the Mark 5: pm me your email & I'll send them.
Cheers
Bryce
Hi Bryce,
Sorry I just worked out it is a MK6 blade as it has the TM4 motor up front.

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

Re: New Blade Electron owner

Post by antiscab » Sun, 25 Mar 2018, 06:39

The tm4 has a hard lower voltage limit of 200v.

How are you measuring 180v? The nominal system voltage should be 320v or 100 lifepo4 cells.

Does yours have the cylindrical cells like in my car?
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

Tango
Noobie
Posts: 3
Joined: Thu, 22 Feb 2018, 17:26
Real Name: Tim Wight

Re: New Blade Electron owner

Post by Tango » Sun, 25 Mar 2018, 19:53

OK I just realized I was only checking the batteries in the boot which after I got the charger going have come up to 201Volts unloaded and stable at 195volts with the ignition on and head lights on.

I measured 325Volts at the input to the SPV-1600 power supply and 14.2volts on it output.

Could relay do with a block diagram or circuit for this MK6 if anyone has one.

antiscab
Senior Member
Posts: 2176
Joined: Mon, 26 Nov 2007, 05:39
Real Name: Matthew Lacey
Location: Perth, WA

Re: New Blade Electron owner

Post by antiscab » Mon, 26 Mar 2018, 10:22

Pm me your email address and I'll send you what I have.

Also highly recommend buying a USB can cable for the Orion bms. You have to contact ewert systems to get them to send you one out by itself.

Alternatively, you can use Android app torque and a obd Bluetooth adapter to read values. Some extra wiring needed to do this
Matt
2011 Blade Electron mk6
2007 vectrix - 145'000km
1998 Prius - needs batt
1999 Prius - needs batt

Bryce
Groupie
Posts: 115
Joined: Sun, 13 Jun 2010, 16:54
Real Name: Bryce Gaton
Location: Melbourne

Re: New Blade Electron owner

Post by Bryce » Tue, 27 Mar 2018, 05:22

Tango wrote:
Sat, 24 Mar 2018, 14:12
Bryce wrote:
Tue, 05 Jul 2016, 00:11
I have the electrical drawings for the Mark 5: pm me your email & I'll send them.
Cheers
Bryce
Hi Bryce,
Sorry I just worked out it is a MK6 blade as it has the TM4 motor up front.
Hi Tim - you should be able to PM me - will look into why not!
With all those different parts - suspect the Mk5 diagrams would be of no use at all.
NB: There is a Mk6 possibly for sale here in Vic with a TM4. I can forward you the details. (There was another one - but I noticed the other day that the business with it in front has closed).

Cheers
Bryce
AEVA Vic committee member; AEVA national newsletter editor
Current EV drives:
2011 Leaf, 2001 Berlingo conversion
Past drive:
2011 Blade Getz
Past Conversions:
DC Berlingo, AC Berlingo, AC Sprinter

Post Reply